For sending emails, custom SMTP now required

In previous versions, Manager could send emails without setup. This no longer works.

Background

Email protocol is abused by spammers who send unsolicited emails and as a result, email providers are employing various anti-spam detection mechanisms to be able to tell legitimate emails from spam emails apart.

In order to make sure that emails sent from Manager are not considered as spam, we’ve been using reputable SMTP relay service from Mailgun.com

Unfortunately Mailgun.com has shut down our account yesterday because our emails look suspicious due to high rate of bounced emails. Because people often mistype email addresses in Manager, we always had higher than typical bounce rate. This hasn’t been problem because our volume was low. However since Manager is used by more and more people every month, we’ve started to send enough emails through Mailgun.com to get on their radar.

We could find another SMTP relay but it would be a matter of time before we’d get shut down again. So we need to move to solution which won’t break.

Solution

You can still send emails from Manager but you will need to provide your own SMTP relay credentials under Settings tab, then Email Settings.

If you have an email address, you have SMTP server you can use (e.g. Gmail). There are also plenty of SMTP server providers who offer this service for free. Many have generous limit. For example, Mailgun.com allows to send up to 10,000 emails per month for free.

The key is that every user of Manager will need to have their own SMTP relay. There cannot be a shared one across tens of thousands of users. One bad actor will eventually ruin it for everyone.

Tutorials:

2 Likes

I know you are busy but for people using their own servers, it would be helpful to know the technical requirements here or at least get a more detailed error that “message not sent”.

For example, currently I have my in house SMTP server working without SSL. However by changing the port to 465 and checking the SSL box, I get no error aside from “message not sent” so I have nothing to troubleshoot. We do have the same server sending out other reports in other software using 465 and SSL so there must be some incompatibility with Manager I just can’t find it due to the vague error.

Manager does not support port 465. Use port 587.

The latest version is making this more obvious. Port field is now dropdown to choose from either 25 or 587.

I don’t understand why. Even though 465 is not RFC compliant for SSL to SMTP, that is still the recommended configuration of a TON of email servers, all of ours included.

Here is a document from Google’s gsuite saying to use 465 for SSL as well. I can use 587 with TLS but it looks like Manager doesn’t support that either.

Even the gmail guide provided makes no mention of SSL enabled.

Because standard libraries don’t implement it. The only way for Manager to support port 465 would be to bundle custom email component which I find unnecessary considering every SMTP server supports 587 as well.

Manager supports 587 with TLS.

Do we just use 587 and leave SSL unchecked and it will automatically authenticate using TLS?

Our mail server accepts insecure on 587 but can be upgraded to TLS using STARTTLS, I am unsure how to do that from Manager.

just did. but this is what i get

“The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at”

are there any other settings i missed?

trying to do the gmail one.

Yeah, that’s exactly how port 587 works. Download the latest version which no longer has Use SSL checkbox.

On the older version where Use SSL checkbox is present, this checkbox must be checked.

Any tutorial on how to set this up with office365? I use office365 with my own domain name (user@company.com)

@Robojock

Can you try these settings?

Hostname: smtp.office365.com
Port: 587
Username: (your Office365 username)
Password: (your Office365 password)

@lubos,

option 1 of this link works only issue is that it then uses the user who was registered as the sender and reply to. This could work but then there needs to be a way to setup every registered user on manager to their own licence of office365.

option 2 works as well but the messages get flagged as spam. It mentions adding a static ip address i don’t know who’s static ip address to add there and where to get it.

Or what do you suggest i do?

@Robojock don’t worry about static IP address as all your emails are sent through Outlook servers. So what you need is just:

v=spf1 include:spf.protection.outlook.com -all

Do you know how to set up SPF record on your domain name?

It is already included. If i use option 2 my mails go to junk/spam folder of the recipient.

My business domain is hosted at Bluehost. They require port 465 for SSL/TLS or 26 (without SSL/TLS).

Will either of these ports be made available in the drop-down list box in email config in Manager? Thanks.

@Robojock TTL is set to 1 hour. Did you wait for at least 1 hour since setting up the record to test?

@finlander Unfortunately only port 587 is supported. In this case you can sign up for free account with mailgun.com or sendgrid.com and use their SMTP server. I will be publishing tutorial for both services today.

1 Like

Lubos, those records where setup about 12 hours ago.

ugh, sendgrid might not be a viable option. The incoming mail server at Bluehost blocked the test message sent through the sendgrid SMTP relay. Other IMAP servers will surely also block sendgrid SMTP relay.

I’ll try mailgun, but they require credit card data as a way of preventing abuse of their systems (no CC charge if usage is less than 10,000 mails/month).

550 "JunkMail rejected - o1678924164.outbound-mail.sendgrid.net [167.89.24.164]:44117 is in an RBL on rbl.unified-contact.com, see Blocked - see http://www.spamcop.net/w3m?action=checkblock&ip=167.89.24.164"

Update: I’m just going to use my home ISP for now. I have 587 option with them and very low volume of emails for the foreseeable future.

Hostname: smtp.office365.com
Port: 587
Username: (your Office365 username)
Password: (your Office365 password)

the office365 setup as suggested by @lubos works for me. thanks

It works yes, only if you are one user. If you are more than one user then no it is not practical. @lubos is it possible to add that every user who uses manager to add there own user name and password for the smtp? So if user “A” has a office365 license and also uses manager they can add their username and password and everytime they send a mail from manager it will be from them.