Manager In English Settings looks Blurry - The Interface Text & # Not Clear

Given that you are the only person in the entire Manager universe reporting this, I can only conclude it has something to do with your systems setups. Possibly, you do not have the entire font families installed?

@Tut Yes I can see that, but all the font families for Helvetica Neue & Helvetica are installed, Arial & Sans-serif as well. what assures this the screen shot I shared in my previous comment where the language is changed to Arabic the program works well, once switched to English or any language that uses English letters, it just gets crisp and unreadable as shared.

Thanks anyway, doesn’t seem that I will find a solution for this problem as I’ve tried everything.

The following should clear your problem. It would have helped if you indicated that this is after a Windows update as this is quite common for non English language systems and caused by Windows 10 to not update this

  1. Control Panel → Appearance and Personalization → Fonts and then on the left panel, select the Adjust Clear Type Text option.

  2. Follow the instructions and choose how clear you’d like the fonts to be and restart all your programs.

This was posted by much earlier on
Complete Tutorial ( With Images ) On How to use Clear Type Text for Window Users.

You must follow all the instructions and apply it to all screens.

That’s all I got, except maybe a browser setting.

Interesting, my default browser is set to Firefox but when I check task manager and expand Manager it is running in Microsoft Edge. In fact Windows is forcing it to run in Microsoft Edge Webview2 run time, and if you uninstall it every time you open manager it reinstalls.

@magedauf Try this, open manager, then go to another browser, Firefox Chrome,ect and enter and see what your fonts look like, this bypasses Microsoft Edge Webview2 run time which may be causing the issue

Running Manager Desktop version in windows DOES NOT use your default web browser (Firefox, Edge, Chrome etc) it uses Windows Explorer. Go ahead, try opening Manager without anything else and you will see Windows Explorer appear in the Task Manager.
However opening tabs/links in a new tab/window (right click) will invoke your default WEB browser. Again check the task manager.
There are numerous references on the internet to the differences between the two.