Windows 10 - Everything seems "Fuzzy"

Just upgraded my Windows 7 laptop to a new Dell running Windows 10. Everything else looks great on the new laptop crisp and clear, however Manager looks “fuzzy”. Anybody have any solution? I am running Desktop Edition.

Many thanks,
Mark

This could DPI scaling issue.

See: https://www.pcworld.com/article/2953978/use-windows-10s-individual-display-scaling-to-perfect-your-multi-monitor-setup.html

Thanks Lubos- but still fuzzy

I have the same issue (Windows 10 20H2 19042.685, Manager Desktop 20.10.97, Webview2 or IE Fallback no difference)

I have a high-DPI display so my Windows Display Scaling is set to 200%.

You can see the application’s title bar is crystal clear, but compared to this and other applications on the system, the text within Manager has been “scaled up” without being smoothed. Like increasing a computer’s resolution instead of using scaling, resulting in smooth text becoming blocky.

This even extends to Windows dialogs launched from within Manager e.g. filepicker:

Other applications within the system including an embedded browser, say itch.io, do not have this issue:

And using the “open in new window” trick to use Manager in Edge or Chrome does scale properly with smooth text (unlike the desktop application). We see the icons are still blurry but that is expected as they are not high-DPI assets, unlike a font which should scale.

1 Like

When you do “open in new window” trick, could you open Microsoft Edge web-browser and copy URL from Chrome to Edge and see if the text is still crisp under Microsoft Edge?

Yep, still smooth/crisp in Edge 87.0.664.66

Is this a possible work around for this ongoing problem.
For a long time I have been struggling with poor quality screen fonts. I even bought a new computer and a screen. The text is not sharp and the 5’s and 6’s look very similar especially in bold. A number of people experience the same problem. I think there is an incompatibility with Windows?
I was having a similar problem with my pdf programme - prints perfectly but the screen was a bit blurry and it was annoying. The following fix was provided for my pdf programme so I applied it to Manager. (Windows 10 pro-system)
Right click on red Manager screen icon
Click Properties then Compatibility
Click Change high DPI settings
Tick Override high DPI scaling behaviour.

If you run manager now it may be a tiny screen font - mine was.
Then go into Internet Explorer - this controls the screen presentation
Click on gear wheel - top right and select internet options
Click on Accessibility
Tick Ignore font sizes specified on web pages.

I find the font is a bit larger (than I want) but it is clear and sharp and a significant improvement. The 5’s and 6’s are clear! :grinning:

WARNING: This worked for me and may not work for everyone - caveat emptor. I use very few of the functions so please record your current settings before testing.

This is a great programme. Maybe one of the programmers can provide a better work around or provide a better set-up.

Thanks @Tsesebe. I personally didn’t like the look with “Ignore font sizes specified on webpages”, but your instructions on a workaround were still quite helpful.

Just to add to this, I then found I had to change Scaling performed by:

  • Application if running in WebView2 mode
  • System (Enhanced) if running in Internet Explorer mode

Choosing the wrong option made everything tiny on my high DPI screen.

So, this is a perfect workaround, thanks! Meanwhile can we perhaps shift this to #bugs and see if anything can be done at the development level to fix for everyone (where everyone == Windows high-DPI screen users)?