Crash when creating pdf on Mac after installing Ver 21.1.23

Hello @HansL,

See post #57 above, I believe this may also be the only solution for (High Sierra) you are locked into Ver 21.1.6 until @lubos is able to resolve if possible with his third-party programmer.


@HansL, have you tried the shut-down and restart l described in my post #57 above? I tried to replicate these problems on macOS 10.13.6 and could not.

@Tut, complete shutdown and restart as in post #70 above does not resolve problem for me on Mojave 10.14.6.

Thanks, I will go back to version 21.1.6 for the time being.

Thanks Damien, I will go back to version 21.1.6 for the time being.

Done downloading it thanks.

I got this message


It appears you are trying to open a file which has been already accessed by newer version of Manager. Upgrade to the latest version of Manager and try to open this file again.

It won’t take the new backup that I did for this year…

@iosephos, see post #61 above, you need to restore from a backup made on or before Ver 21.1.6 as the backups are not backwards version compatible .

1 Like

I have same problem: I am using a MacBook Pro - Mojave 10.14.6, with a Desktop, Manager 21.2.4 which was recently updated. Once you click the backup button, Manager opens the window for backup with file name but it does not open the Finder for saving manager backup file ( thats how it was previously saving), cannot print in PDF, the software crashes. none of the Copy to Clipboard button work, does not work.

I tried this too, it does not work, it looks as though the backup files are not backwards compatible

Actually, your problem is that on the older version of the program, they were not forward compatible. On the newer version they are.

I have encountered some technical issues since updating from 20. (something) a couple of days ago. crashes each times I hit the PDF button. Does not print. Also, app hangs when trying to backup.

Any help would be greatly appreciated.

Edition? Operating system? Exactly what is the “crash” behavior? What happens when you try to print? What does “app hangs” mean exactly, and what stage of backing up does it occur at?

I am using Mac OS High Sierra (10.13.6).

Manager crashes and closes as soon as I hit the PDF button when in invoices.

I have attached a screen shot of the print message when I try to print.

I have also attached a screen shot of what happens when I try to back (it would normally ask for location, now it just sits with back up greyed out.

Print message

Back Hang

@Matt it appears that updating from Manager 21.1.6 to Manager 21.1.7 has triggered all the issues see crashes when creating pdf on MAC after installing Ver 21.1.23 lengthy discussion. See post #57 of the this post, I believe this may also be the only solution for (High Sierra) you too are locked into Ver 21.1.6 until @lubos is able to resolve if possible with his third-party programmer.

Thanks Damien for your reply…I installed 21.1.6 and have the internal error message. How were you able to over this issue?

Hey mate, I just tried “go back” and trying again and Manager opened up. So it appears to be working. Only get that message when closing the app completely and going back in.

Thanks again for finding a reasonable solution.

@Matt, your post and the discussion it generated were joined with the existing topic on the bug. In the future, please search before starting new topics. It is confusing and time-consuming when discussion of an issue is scattered through multiple threads.

@Matt it appears a solution is near thanks to @ norfolkislandam post #29 of Crashing after installing new version 21.1.17.

For the time being, when desktop edition on your Mac is running, can you go to Safari or Firefox and type:

This should allow you to work on Manager with printing and PDF working until the issue is fixed within the proper Manager window. Thanks to @Tut and @lubos for a temporary fix and eminent final fix in a few days.

That solution sounds equivalent to

Then minimise the original window and work from the second window

Hi All
I am having the exact same issue with printing and Manager crashing. Backups also don’t present the finder window for saving the backup.
Running Mojave 10.14.6 and Manager IO 21.3.31
Hope to get a resolution soon.
Have tried all the solution above, including the Full Shutdown of the Macbook and restart, made no difference