Crash when creating pdf on Mac after installing Ver 21.1.23

I need help urgently. All previous work appears to be okay.

I just updated to Ver 21.1.23 I was previously using 20.11.19? I think? Now I can’t send to a PDF program crashes, nor print an invoice get the following

“There is no application set to open the URL eto:print.”

Search the App Store for an application that can open this document, or choose an existing application on your computer.

Also Backup does not save file to desktop anymore - appears to be doing something but file is not saved anywhere. No option is provided as to where to save file.

I cannot reproduce any problem.

First, Manager does not print PDFs. The options within the program are:

  • To print directly. In that case, you are using your operating system’s printer drivers, not any function of Manager.
  • To create PDFs. Manager does that internally. Doing this provides interaction through the Finder to name and save the PDF to wherever you choose. I just tested in v21.1.23. It works perfectly.

Backups will be saved to wherever you select in the Finder window during the backup process. If you choose to back up to your desktop, it will back up there. I also just tested that, and there has been no change with version 21.1.23.

No option is given where to save

You need to describe the series of actions that produce this behavior, click by click. Illustrate with screen shots.

Problems identical to

Same MacOS 10.14.6 and later Version of manager problems after install of v21.1.23

Get this message when I open manager.io in bottom LH corner

/Users/shaddoe/.local/share/Manager[Change Folder]
21.1.23

Please do not reference your own post, which did not contain important information, to answer questions about what triggered the problem. If you want help, answer the questions.

That is the current location of your application data folder. See the Guide: Move desktop application data to another folder | Manager

When I print I get the following msg!

When I send to PDF the Manager hangs for about 5 seconds then closes the Manager program.

The program worked perfectly before the upgrade. This user appears to have identical problems

Perhaps. But that user was also reluctant to share much information and seems to have disengaged from the discussion. Both of you seem more interested in explaining that something used to happen with a version of the program you don’t have any longer than in providing needed information to tell whether something might actually be wrong with a newer version.

Meanwhile, if no one can reproduce the problem, it will not be addressed. So I repeat my earlier request for you to provide all the requested information.

That is exactly my problem too. And if Iwant to print I only get a window that ooens which tells me I do not have the software to print I have to choose a program om my mac or download from Appme store. When I click on Download from apple store it only states this is not supported in your country. So O just email the stuff to my seld and then print from my email. But the Tax Summaries does not allow me to email. Guess we are scr…ed after the update.

Thank you for your, response I do wish to find the problem and the solution.
Backup does not save file to desktop anymore or anywhere else - appears to be doing something for a few seconds but file is not saved anywhere. No option is provided as to where to save the file.

Snap screens of message above for when “I open Manager” also the message received when “I attempt to print.” When I save to PDF the program crashes. Do you require any further information?

I certainly hope not, I am attempting to work it through with Tut.

Yes. As I requested in post #4 of this topic, describe what triggers the issue, click by click from the beginning. Please do not tell me you have the same problem as someone else. And do not say you have already furnished the information. You need to furnish all the information so someone can follow your actions to the same end point.

But let’s start by determining whether you followed the update instruction in this Guide: Install or update desktop edition on macOS | Manager. Did you?

I followed the procedure as per the guide except I chose replace and not keep both copies as I had done the upgrades previously without errors. Guess that was a big mistake!

I opened manager.

Selected my business. Selected Sales Invoices. View an existing Invoice. Select PDF - then the program crashes.
A screen appears “Problem Report for Manager” “Manager quit unexpectedly” Etc

I opened manager. Selected my business. Selected a Sales Invoices. View an existing Invoice. Select Print and get the following msg:-

I opened manager. Selected my business. Selected Backup and second screen opens displaying the company Name as below.

I then selected the Blue Backup button dots appear to the left of the button and the button changes to a pale Blue. No option as to where to save file is requested. Appears as below.

Is this all you require?

I have just tried Backup with all three boxes unchecked ( I have no emails or attachments as far as I am aware, Some 20 pages of history) I waited 6 minutes. Still no Backup produced.

Thank you in advance for your consideration and assistance with this problem.

It is a sufficient start for @lubos to begin looking into the PDF issue.

As for the backup problem, how long did you wait after clicking the Backup button. It normally takes a while to assemble the backup file, especially if you have a lot of emails and attachments or your history is long. Try making a backup with all three boxes unchecked.

I just made a backup using Macbook Pro Big Sir 11.1. I do use the Cloud version. Nevertheless, there is no notification the backup has been made if you have “told” your browser to automatically save your downloaded file to the standard folder, most likely [Downloads].

1 Like

Unfortunately I exceeded my posts so was locked out and unable to respond sooner.

I have checked downloads no file saved there also checked the whole drive. Changed settings to desktop in Firefox still does not save Also changed settings in Firefox to “Always ask you where to save files” and it does not ask when “Backup” button is selected.

I have tried Ver21.1.27 and kept both versions newer version also generates the same errors.

Hopefully you will be able to provide a solution. Thank you in advance for your efforts. Only realized today you are Aussies from the east. Great work guys.

Which processor does your Apple have?
I will install the desktop version of Manager on my Macbook Pro with Intel processor and see what happens, trying to, kind of, duplicate your situation.

Just out of interest, what do you mean by “Aussies from the east”?
I am Dutch, so my knowledge of Australian sayings is at a minimum…