Crashing after installing new version 21.1.17

Need help please. I installed new version of Manager, and if I want to print or save as PDF or email, the program just crash, is there is bug need fixing?

You need to furnish more information. Are you using desktop or server edition? What is your operating system? Exactly what triggers the crash?

It is the desktop version. I still worked on an older version this mornig and everything was fine but after I loaded the new version my headaches starred. My company opens but when I go to an invoice and want to save it as PDF it just boms out and I have to restart the program. If I want to print it states the following " There is no application set to open the URL eto:print. Also in the left lower corner the following messages appears which was never there" /Users/WMAAdmin/.local/share/Manager “change folder”’. I tried to reinstall the older version again but when I open it only shows an “internal error” message. I also tried to load the program on another mac here in the office. Also with exactly the same problem. Regards Leo

First, you have not said what operating system version you have. I surmise you are on a Mac, but what version of macOS?

This has already been reported. Please search the forum before starting new topics.

That is the location of your application data folder. This was added when the Preferences tab was recently removed. See the Guide: Move desktop application data to another folder | Manager.

What is the “it” that states this? Please post a screen shot. How did any URL become involved?

What internal error message? Please post a screen shot of it.

Your final screen shot shows an error message thrown by your computer, not by Manager. Combined with other things you wrote, this suggests some type of network printing setup error.

Okay I am back at work now. The Mac version is Mojave 10.14.6 Hope that helps?
Regards
Leo

There was definitely no such problem associated with macOS 10.14. And your version of Manager didn’t crash when printing or creating PDFs. So it really looks like a network printing error.

The existing bug is when importing backups.

Other reports of trouble do not match your circumstances.

I also installed the new version 21.1.18 this morning, I still get the same errors. I can’t print any invoice on your system anymore, I can’t save anything on your system as PDF’s anymore, and I also can’t email any invoices from your system anymore
All my other programs works 100% for printing and email and PDF, it is only the “Manager” program which gives errors.
The Manager program is only on my workstation, not on the server at all, and I have a Canon Pixma printer attached to my Mac, where I can print directly to. As I mentioned yesterday even if ~I~ install manager on another Mac, it also shows me the the following error /Users/username/.local/share/Manager "change folder, in my instance it is WMAAdmin, on the other macj which is JWATech4 I get the same errors, if `I click on that it opens a white-ish new window and just nothing happens.
1.If I try to print the following message" " There is no application set to open the URL eto:print.
If I try to save as PDF the program just close
If I try to email the program also just close

I downloaded the manager software to all our machines now, and created new companies to see if it is something with my machine, all of the machines on Mojave have exactly the same problem, only the Owner’s machine which is in Mac OSX Catalina is printing, PDF and allow for email.

Where can I find the files on my machine to install it to the boss machine, as my last backup was 12.11.2020, as we closed for the holidays? I tried to do a backup now, on my machine but that also does not work? If I open the program everything is there, it just do not want to Print, email or PDF, or backup, so if I know where to find the info on my machine I can put it on a memory stick and load it on the boss machine to do my VAT returns and PAYE, please?

Lastly please I do apologise for my bad English, but I try my best to communicate

Regards

Leo

Your data files are in the application data folder at the path specified in the black box. I already explained that in post #5.

where can I find the post #5 you mention here? Please bear with me that my mother tongue is Afrikaans and my English is not good and it seems to me if you are agitated, we are not all Computer experts and therefore we politely ask for your assistance as the problem started after I installed the new version of the program yesterday?

I search that Users/WMAAdmin/ which shows in the black box at the bottom of your program but my Mac does not find such a folder/ or file, not on any of the computers with Mojave installed, only the one with Catalina. If I click on that black box I get a white screen, and the program shuts down, even on the other machines with Mojave where I installed Manager and I tried to create test companies to see if it is only my machine give exactly the same errors, only the machine with Catalina the program works 100%

Kind regards

Leo .

It is the fifth post in this topic.

As stated in the Guide linked in post #5 (of this topic), the file is hidden. To view hidden files on a Mac, press Command + Shift + (that is a period or full stop as the third key). Press that combination again to restore normal viewing.

Tests were just run that verified the current version of Manager will run on macOS versions as old as 10.13. So it will run on 10.14. There is something about your setup that is causing the problem. I cannot diagnose that remotely.

Was your problem resolved I have just installed Manager Ver 21.1.23 and I am experiencing the same problems I am unable to print, unable to create a PDF. Also I cannot create a backup file.
I am using macOS Mojave Ver 10.14.6. The program was working perfectly before the upgrade.

See my Post

anybody have manager release from beginning of the month for mac?

Hi Leo,

Try updating your MacOS I had the same problem when I try fresh install on 2013 MacAir (see my post). Same errors resulted so i upgraded macOS to Big Sur V11.1 the down side - some applications don’t work unless upgraded - some upgrades are free other cost $$$. Now Manager works perfectly again. I haven’t done macBookPro (2012) as Catalina is highest upgrade allowed. Investigation show several applications will no longer work. So waiting to see if there is another option.

No I also still have the same problem. Ont he mach8ne w8t catalinaI can print but the mojave machines does not work at all except email. No PDF and no print fromManagee program.

Also installed version 21.1.30, still the same problem

Hi Damien,

My problem is that I cannot upgrade to Catalina or higher, as our previous company worked on Account Edge, and Account Edge will not upgrade their system to work on Catalina. We are busy the past two years to close that entity, but due to unpaid invoices from one of our clients, we cannot close the company down and deregister it at this time. Guess my only option will be to work from the manager’s machine then
Thanks for your help, I do appreciate it

regards

Leo