Crash when creating pdf on Mac after installing Ver 21.1.23

Attachments are not opened by Manager. For example, a *.xlsx attachment would open with Excel.

I can verify that I also get a white screen and the Manager desktop program crashes if I use the PDF button on an invoice. I just installed Manager on my computer last night and would love to use this program! I’m using version 21.1.30 of Manager on a Macbook Mojave 10.14.6.

I also get the “There is no application set to open the URL eto:print.” error when clicking on the Print button on Invoices. And, when I click on the “Change Folder” button in the bottom left of the screen to change where the file is stored, I get a white screen but the program doesn’t crash.

What happens if you update your computer to macOS 15? If you can run Mojave, you can run Catalina, although you will have to update or abandon any ancient, 32-bit applications. It’s free.

MacOS 10.14.6 is becoming a common characteristic of similar reported problems.

Thanks for your response! I can’t update my computer at this time…running some 32-bit programs I’m not ready to part with.

Have you tried running the windows version in Wine?

I haven’t…thanks for the idea. Would an older version of Manager work with Mojave? I’d prefer that option at this point.

As dram mentioned, older versions can be downloaded from Manager’s Github page:

That will depend on the cause of your problem. All versions of Manager released since Mojave came out (and probably all earlier ones as well) have worked with Mojave. There was a temporary software notarization issue when Catalina was released. But that was quickly resolved. I have expressed the opinion on all forum topics raising similar issues that the problem does not lie with Manager, but with some aspect of your individual setup.

I have personally run all my businesses on almost every version of Manager on every update of macOS since v10.9 (including the main and incremental updates). I have never encountered what you describe.

The Ver 21.1.6 of is the last version that will work for me with Mojave. Is anyone using a later version on Mojave?

Hi @Damien_C,
Version 21.1.6 of for desktop works on High Sierra (10.13.6) also. It may be that newer versions failing is an Eto or MonoMac problem that is outside @lubos control. I suspect that there is insufficient demand for supporting older operating systems that we will have to continue using this version until we can update our hardware/OS.

As far as my business file is concerned, I always backup my business before upgrading to a new version for just this reason. There is no way of knowing whether the business file will be modified by the new version and there appears to be no way of reverting back if it does happen.

Hence, I locate my business file on DropBox, which automatically creates a backup after every change in your business, although you can pause DropBox sync for 30 mins or 1 hour. I also make a manual backup to the local disk after every monthly reconciliation. Only then do I consider installing an update. Using Time Machine, the manual copy is backed up to a network drive on a regular basis whenever changes occur.

Unfortunately, none of this helps you get up and running again without re-entering months of data.

Dear Lubos I also still struggle with exactly the same issues, and unfortunately my machine is way too old to upgrade to either Catalina or the new Sir, I have an old Imac late 2013. I also installed the new version today of your program, still with the same errors. For the time being I forward the invoices to my email as that is the only option that work, when I want to print something, but that is not the case with everything, when I do trial balance and try to print, I get the following: Screen Shot 2021-01-20 at 3.46.09 PM. When I try to PDF, a new white screen opens for a few seconds, then the program just bombs out, and one has to restart. When I click on copy to clipboard also nothing happens when I want to paste it into Excel sheet. I also put an older back up (as new backups do not show anywhere) on an external drive as well as the following files

to see if it works on the manager’s machine which is almost brand new, but that also just gave errors, meaning I am back at my own machine. Could you please help as I am desperate, the auditors need trial balances in Excel format, and all I can give is screen shots, so they are not happy at all? Kind regards Leo

Hello Leo,

Have you considered running a free trial of the Cloud Version to get you out of trouble from one of your most recent backups. It seems to run error free in the Cloud on any version of MacOS. I went through painful process of getting my older version up to date, then entered data back into Ver 21.1.6 ( the last one that works on Mojave). That way I can retain all the 32-bit software for now.

i updated the program yesterday too. but i got the same error when i selected invoice to batch pdf. i liked the new feature and i wanted to try it to batch pdf. but i selected batch pdf the error occured as above said.
it was in windows 10 64 bit, manager desktop

Facing same issue on my MAC running on Mojave OS. Cant print and when i click on PDF, Manager is crashing.

Hi Damien. Yes I am also busy with the clowd version now. Did back ups 3 months ago so that is quite a job to process all those entries online. Only at the second entity now. Will check when I finalise the entries to install the version you mentioned. Will keep you posted thank you.

Will it be possible to dropbox me that version as I deleted it and cant find it online, please?

have a look at github, in particular

Previous release versions available from ( · GitHub)

This link will get the version needed before it breaks on Mojave 10.14.6

1 Like

thanks a million, you are my hero. Will install and see if it works. Will not update soon again…lol

Hey Leo,

You’re welcome, glad I was able to help get you over the line. Good luck.