Programme is freezing or running extremely slow

I have noticed that the last two updates are causing the programme to either freeze completely or extremely slow when trying to select another section, except for back which works perfectly.

Obviously we haven’t added anything that would suddenly cause any slowness. Here is what you should try…

  1. Try to install Manager on different computer and import your accounting file there to see if the slowness persists.
  2. Create new business on your existing computer, fill it up with some dummy data and see if the slowness persists on brand new file.

Let me know conclusion.

I created a dummy file, only put a couple of entries, everything is fine, but still freezing on main business

Sorry but that file is now freezing I will have to swap to another computer

When you transfer to another computer, do you experience the same issue? I’m trying to determine whether it’s something computer-related or data-related. If you experience the same issue on the 2nd computer, then it would be a bug in Manager and you should send your accounting file to

Hi, I’m not sure if this is the right place, but I’m also experiencing freezing when the programme is inactive. If i minimise it and then go back to it after doing other things, I don’t seem to be able to make any of the tabs on the left hand side active. If I completely close it and re-open it everything works, but once its left minimised it freezes again. I’m running it on a macbook and a mac and get the same problems. Please could you let me know if there is a setting or something I may have missed setting up which should stop this happening? Many thanks for your help.

I had that problem a while ago, Lubos suggested I check the start date, mine was something weird like 01/01/01, so I changed to my earliest date I needed. It seemed to fix the problem, but even now it will cause the spinning wheel, but rarely.

I’m aware there is an issue on Mac when you leave the program minimized for some period of time, it will stop working and you will have to close the program and start again.

The problem is, I’m not able to reproduce this issue myself but you are not the first one observing this.

Any idea how long after minimizing it takes for Manager to stop responding so it needs to be restarted?

I’ve just tested it and it seemed stable for at least 30 minutes, so I would say probably after about 45 minutes it would start to freeze up. I’ll run it again tomorrow and see if i can get a more accurate timing.

Well, that was jelly convenient! I just tried to change tabs in the programme and after 32 minutes its frozen again.

I’ll try to reproduce it myself. I didn’t wait more than 30 minutes so I’ll give it another go.

Hi Lubos, any progress on this one yet please?

My programme freezes if just left idle - i.e. not minimized. I am using Mac 10.6.8.

I continue to have this problem also. (I’ve reported it before.) In my experience, the program window does not need to be minimized. And I’ve had it happen after as little as 30 seconds.

Hi everyone. I’m new to this forum and brand new to the Manager app itself. So sorry if this has already been fixed, or if my suggestion is way off… But if it’s a Mac-specific problem, is there any chance that it could have something to do with Apple’s ‘App Nap’ feature? My project management software (iBiz) stopped working properly in OS X Mavericks (and now Yosemite), but it’s possible to keep using it by disabling App Nap for just that app. Might be worth a try for Manager, to see if that’s the cause?

Brilliant idea! I didn’t even know App Nap existed. I’ve disabled App Nap for Manager and will wait to see what effect, if any, that has. Unfortunately, the exact circumstances that triggered the unresponsive state are hard to pin down, so it may be difficult to tell if this is a solution. If it is, it may have to be re-implemented at every update unless @lubos can incorporate a permanent exemption. I’ll update this thread with anything that seems to have changed.

Quick update: with installation of the latest version of Manager (v15.2.4), my prevention of App Nap was preserved. It occurs to me that this may be because each new version of Manager shows as v1.0 in the OX X Finder. In other words, OS X doesn’t recognize the upgrade. While this quirk has been slightly irritating, forcing one to open Manager to check the version number, it seems to have a silver lining.

So far, there have been no freezes since preventing App Nap one day ago. Has anyone else tried this? If so, what are your results?

Hi All,

I tried the disable App Nap solution but I still get the freeze up on my Mac. In fact, now my menu options along the top also seem to freeze with the exception of the back button.Unfortunately for me this solution doesn’t seem to work.

What you describe, @icrashin2000, is how this problem has always manifested for me. Neither the tabs nor the top menubar items work, only the back button. Do you know for sure you experienced different behavior? Or is it possible you just hadn’t noticed the menubar aspect of it? The reason I ask is that if we see different behaviors, there may be more than one problem responsible.

Just for diagnostics’ sake, I’m going to leave Manager running all day today to see if I can force the issue.

@Tut, to be honest, I probably hadn’t noticed the menu bar aspect other than the back button. But just as a test, I tried running Manager with and without App Nap in quick succession and had the Back button working and the Guides button but nothing else. Also, under both tests, Manager froze up the minute I pressed the red X and then re-opened it. Completely closing Manager and re-opening it brought back all functionality, which has previously been noted here. Also, I’ve found in the past, there is no set period under which this happens, I’ve had it freeze virtually instantly on red X’ing it, and under continual use, i.e. journalling, PO listing etc. it’s taken from around 30 seconds to 30 minutes, so there is no real pattern to this in my experience. I don’t know if any of this is useful but thought I would note it here in case something helps towards a solution.