Pdf - Manager freezes after using pdf button

Ubuntu 16.04
Manager desktop 18.4.6

Whenever the pdf button is used the pdf file is produced as expected but Manager becomes unresponsive to all options except the window close button.

Manager can then be restarted and operates as expected until the pdf button is used again when the same error occurs.

Pdf’s can be created as expected however by using Print and ‘print to file’ options.

Best wishes


Have you search the Forum, there have been other recent topics regarding PDF.
Can’t recall if they match your issue.

Yes indeed there are a number of posts about pdf formatting and about complete non-printing.
I didn’t find any others specifically about freezing after printing.

I’d be interested to hear if anyone else has experienced the issue.

Also update your software. There were a couple of issues fixed around that version that might be related. So an update might resolve things.

updated to current version of 18.4.18 and problem persists.

There have been many about freezing while trying to create PDFs, which is what you first said your problem is. Now you seem to imply the problem is when printing. Which is it?

Also, does this happen in all tabs? Or only, for example, for sales invoices?

And, are you using a custom theme? If so, does the problem persist when using the built-in, Plain theme?

I’m experiencing the same problem. Only seems to have started over the last 3 days.
Currently using ver. 18.4.2.
The problem exists in all tabs, Invoice, Delivery Note, you name it. Select the PDF button, everything works fine and PDF is created and saved to a file, but then on attempting to close the PDF and return to Manager everything freezes and the only solution is as @ukga says, is to close down Manager and start again.
I’ll head over to Downloads and get the latest version although from what I see @ukga seems to be having the same problem on the latest version as well.

Sorry, I forgot to mention that my OS is Lubuntu 16.04

I’ve just downloaded version 18.4.31 and the problem persists.

Further to the above problem, Manager is working perfectly on my netbook using ver. 18.3.45. The OS is Bodhi Linux v 4.5.0 which uses Ubuntu 16.04 as its platform.
A puzzled puppy here.

I’m using MX linux, and am having the exact same failure



Have you updated your software, @PerryJ? This thread was about problems from hundreds of versions ago. A great deal of work has been done on the PDF generator since then. What version are you using?

debian gnu/linux 9 - stretch
Just updated 2 days ago
updated Manager at the same time

Yes, but please confirm the version number. “Updated Manager at the same time” doesn’t tell anyone where to look.

ok - Manager 18.11.68

Thanks. There is no suggestion of a bug in 18.11.68, as no other user has complained of this on that version. Have you rebooted the computer since the update?

yes, rebooted, checked for updates, updated mx-17, still the same

Can you give more details? What can you do? Does this happen in all tabs? Is there any error message?

Hi everyone,
I’ve been using Manager for over a year without any problems (also been learning how to use it). Today, 11 May 2020 when I wanted to create a PDF file the application froze and stopped working and closes.
It created a PDF file of zero size and Adobe Acrobat Reader DC can’t open what appears to be an empty file. I can create a PDF file from Excel without a problem.
I’ve tried un-installing and re-installing Manager without any luck. Problem persists.
Please help me if you can.

What edition (Cloud, Desktop, Server) are you using?
What version are you using?
What platform are you using (PC, Mac, Tablet,…)?
What Operating System are you using?
What are you trying to create a PDF of?
Have you tried creating a PDF of other reports and transactions in Manager - does that work?