DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Manager keeps freezing


#1

Hi, Manager keeps freezing on me. I can create pretty much anything (new customers, invoices, etc) without issue but as soon as I try to upload my logo or delete anything, it freezes instantly. I have tried creating a new business to start from scratch - same issue. I’ve tried waiting it out - stays frozen. I’ve tried uninstalling and reinstalling Manager - same issue. Nothing seems to be working. I am using a Macbook Pro and have the latest version of Manager. Is there a fix for this because it’s super frustrating.

Thanks in advance!


#2

There is something undetermined (but well known to the developers) that causes Manager to freeze randomly on Macs. Everyone who has reported this says that closing the program and restarting restores functionality without loss of data. But your problem sounds different. What version of Mac OS are you using?


#3

I am using Yosemite v10.10.5. I’ve also tried restarting Manager but it freezes no matter what.


#4

OK, thanks. I’m also using v10.10.5 and have never seen that problem, though I do see the occasional, random freeze that I mentioned before. @lubos will need to sort out your problem. I assume you are using an up-to-date version of Manager?


#5

@Chelle, you are technical, can you try to install server edition on your Mac to see if the problem is the same?

Here is tutorial: http://www.manager.io/server/tutorials/mac


#6

@Tut Yeah, I’m using the latest version of Manager. @Lubos the files I downloaded are .exe files which Mac doesn’t support. I got Mono fine but Terminal keeps telling me the file or directory doesn’t exist.


#7

My question would be how you got .exe files? Are you sure you downloaded the version for the correct operating system?


#8

I followed the link you gave me. I downloaded Mono from step one. Then the link in step two automatically opens and unzips the file. I didn’t get to choose what the file was. It just automatically did it from the step two link.


#9

That link was from @lubos, not me. I should stay out of this, because I only use the desktop version. Please forget that I asked. :blush:


#10

Oh. Haha. Didn’t read your name sorry. Just read the response.
@Lubos I just had a look on the tutorial link sent to me for the Mac version and it specifies .exe file in step four which is exactly the file that downloaded. Perhaps a link issue? Not sure how to access another file type because it’s all done automatically from the links in the steps.


#11

@Chelle, when you launch command:

mono ManagerServer.exe

You need to make sure you have navigated in your terminal to folder where you unpacked the archive. Otherwise mono command won’t be able to find ManagerServer.exe

If you don’t know what I’m talking about, have a look at http://superuser.com/questions/432719/how-can-i-go-to-documents-folder-in-mac-with-terminal


#12

Oh! One little typo and it screwed me up. Thanks for that. Yes, I have been able to delete the file I wanted to immediately. Problem is, I don’t think there’s a free version of the Server Edition is there?


#13

The reason why I asked you try server edition was to do a simple isolation test to see where could be the problem.

The fact it works on server edition is actually bad news for me because I still have no idea.

By the way, what web-browser did you use? Could you try it on Safari?


#14

Ah ok. Bugger. Was hoping that might give you a clue. :frowning: I used Firefox.


#15

Try Safari. If it doesn’t work on Safari, then we are getting somewhere.


#16

Yep, it’s working on Safari, too.