Problem opening v20.9.79 on new Mac computers

I have the same error. Running mac 10.15.7. Manager v20.9.79. Error message shown:

20.9.79: System.TypeInitializationException: The type initializer for ‘Manager.ApplicationData’ threw an exception.
—> System.IO.IOException: Read-only file system
at System.IO.FileSystem.CreateDirectory(String fullPath)
at System.IO.Directory.CreateDirectory(String path)
at Manager.ApplicationData…cctor() in C:\projects\manager2\Manager\ApplicationData.cs:line 54
— End of inner exception stack trace —
at Manager.ApplicationData.Get(String entityId) in C:\projects\manager2\Manager\ApplicationData.cs:line 103
at ManagerDesktop.Program.Main(String args) in C:\projects\manager2\ManagerDesktop\Program.cs:line 36

No, @SheldonSwanepoel, you do not have the same error. You have a different operating system. You get an error message, whereas the other person did not. Your post has been moved to a new thread. It was not related to discussion of a Windows problem.

Can you please post a screen shot of the actual error message, not a transcription?

Also, have you ever modified the location of the application data folder?

No I haven’t moved anything. Its a new laptop, so this is just trying to install and open Manager. I’ve tried uninstalling it and redownloading/installing a couple time too, each time the same issue. And to pre-empt it: Yes I’ve downloaded correctly, and dragged into applications folder to open. Screenshot attached.

You say you are running this on a Mac?

The application is trying to create a folder on a windows box, or it’s at least trying to, thinking it’s on a windows box. Have you copied a preferences file to a mac?

This error message is thrown by macOS, not by Manager. Are you sure you downloaded the Mac version of the program?

Yes I’m sure, I did double check that too. And it downloads a dmg as expected.

And as to copying a preferences file to Mac, no. Its a brand new Mac, not setting it up from a backup or anything. Literally right out of the box, and Manager was the next app after Chrome and WhatsApp that I downloaded.

Ok, what you have there is a little odd. Don’t worry, I do believe you are running the OS-X version, the windows executable just won’t run on a mac, the error is quite explicit and the output of the error message indicates something is amiss.

Manager is attempting to create a directory, which is failing and so lubos has raised the error and we can see the string that’s causing the problem. It’s obvious that the type initialiser for Manager.ApplicationData has thrown the error (it’s explicitly stated in the error message) and is indicative of a missing file (or folder).

Only @lubos can diagnose exactly why it’s happening, because you shouldn’t be seeing those windows style references in the error dialog.

One thing you could try is checking out ~/.local/share/Manager folder and delete anything in there (except your business file if it is there).

Just out of curiosity, what’s the model and specs of the mac?

I just did a little experiment. After safely backing up all my data, I deleted the Manager application bundle and the entire application data folder so I could simulate a clean installation on a new machine. I downloaded v20.9.79 and installed it per instructions in the Guide: https://www.manager.io/guides/7116. I did this to ensure there were no relic files being relied on.

The program installed and launched normally, opening to a Businesses page with no businesses. It created a new application data folder at the default location. The only two files in the application data folder were the 000…000.manager index file and the size file. All this was exactly what I expected. I dragged my backups into the application data folder and they appeared on the Businesses page. All open normally with all data and settings intact.

So, @SheldonSwanepoel, I don’t think there is anything wrong with the Manager download or application. It looks more and more like you have bad data somewhere. Can you navigate to your application data folder and post a screen shot of the folder contents? It should be at:

/Users/username/.local/share/Manager

The folder will be hidden. To make hidden files visible, press command + shift + . while in the Finder. Repeat to hide them again.

Using 2020 MacBook Pro, 2 ports. Screenshot below. Also, I don’t have a .local? I’ve also tried typing that path (using my username obviously) into spotlight and nothing. Manager has not had the chance to launch though, so would it already have created a local file?

Also, I just created a new administrator user on my laptop, and tried to install from there (after removing from applications on my current user). Got the same error.

Yes, you do, or you did not install the program properly. After installing the program and toggling hidden files to display, go to:

Computer (whatever you have named yours)
Users
Username (the administrative user who installed the program)
.local
share
Manager

The last folder, named Manager is your application data folder. The contents of that are what I am interested to see. As noted above, if this folder does not exist, you did not install properly.

The issue is not how I install it. If it hasn’t created a folder (which it hasn’t), its not because I didn’t install properly. To prove this, I erased my laptop and re-installed the operating system. I then didn’t do anything else before installing manager - didn’t connect my iCloud account, didn’t set up Touch ID, nothing. Literally just created a user and went straight to manager.io and installed, so this is as clean a slate as you can get (bar connecting to wifi).

Such outside links violate the rules of the forum and terms of service. Yours was deleted.

Did you modify your System Preferences to allow installation of software from authorized developers as specified in the Guide?

That was already enabled as standard. I’ve now done another erase and install OSX, this time using internet recovery rather than local recovery. Again, I have the same issue and the same error dialogue. And still no .local/share/manager folder.

I was not aware of that, although I didn’t look at the link. I assumed it was just a video file of a debugging attempt.

The closest I could find was

  • the Content is not spam, is not machine- or randomly-generated, and does not contain unethical or unwanted commercial content designed to drive traffic to third party sites or boost the search engine rankings of third party sites

  • your content is not getting advertised via unwanted electronic messages such as spam links on newsgroups, email lists, blogs and web sites, and similar unsolicited promotional methods;

Be non-commercial. Do not solicit customers or recruit employees. Do not offer products or services. Do not post spam or otherwise vandalize the forum

@SheldonSwanepoel, the only other possibility I could think of was that my earlier testing was done on macOS v10.15.6. So I just updated to v10.15.7. I cannot duplicate your problem. So it has to be something with your machine or something you have done. I have to back away from the issue. Maybe @lubos will have some idea what is wrong.

I was thinking exactly the same thing, I did what you did (with the exception of upgrading) and tried breaking the install, it worked every time.

@SheldonSwanepoel there is something crazy happening…

out of curiosity, run a hash over the dmg file.

md5sum Downloads/Manager.dmg 
de4052d297bfcdd96756d5a88846bcfb  Downloads/Manager.dmg

I’m clutching at straws here, that is, just trying anything to help diagnose this for you, but I’m wondering if the file system could be an issue because I believe windows and .net are case insensitive, but mac’s and linux usually are… again, I know, just clutching…

if you could run: diskutil info /dev/disk1s1 (if you only have one partition (doubtful because of the recovery partition) you may need to specify just the drive diskutil info /dev/disk1 and we could compare results.

My thinking is, manager is looking for something based on where/how it’s installed, or some system idiosyncrasy that’s upsetting it. If the hash is the same, then we’re using the same uncorrupted download. Two mac users (@tut and myself) have confirmed we have it working as a new install, the OS’s are most similar (via @tut’s upgrade, they are the same), just trying to think outside the box.

My result:

 diskutil info /dev/disk1s1
   Device Identifier:         disk1s1
   Device Node:               /dev/disk1s1
   Whole:                     No
   Part of Whole:             disk1

   Volume Name:               dav3Sierra
   Mounted:                   Yes
   Mount Point:               /

   Partition Type:            41504653-0000-11AA-AA11-00306543ECAC
   File System Personality:   Case-sensitive APFS
   Type (Bundle):             apfs
   Name (User Visible):       APFS (Case-sensitive)
   Owners:                    Enabled

and also, just for the hell of it, also output the result of:
cat ~/.CFUserTextEncoding
for me, it is
0x0:0xF

If the first value is not zero, that could also explain the issue as that is to do with logged in user access to the home directory… yes, clutching at straws.