Mac Installation issue

I’ve been using Manager for a while, though not intensively, and I have just downloaded the current version to install onto a MacAir running Catalina 10.15.4. It is installed in my normal place for 3rd party software, in its own folder. Adjacent applications work as expected.
When I start up Manager I get the error on the attached screenshot.
Is this originated in Manager or the database manager?
The console appears to show no errors.

You need to follow the Guide — Install or update desktop edition on macOS | Manager — and install Manager in your Applications folder.

Thanks Tut
Of course,

(I knew that)

But when I re-check and re-install I get the same issue

A previous version 18.9.94 is running happily in a sub folder off the system applications folder.
It has 4 sets of accounts. Interestingly, it is necessary to expand the first screen, the list of companies, to full size before it shows any data. reverting to normal size retina the data.

The new version i downloaded, when installed alongside the previous, does not start. You will tell me not to have 2 installations, and I have read your thoughts on forward only compatibility, However, to carry out some regression tests - like ‘Does it start up?’ before any upgrades of the database, I first ran the existing config, which was OK, apart from the weirdness with the opening screen,
Then, rename the .app, restart the PC, re-install Manager as per your guide - into the system applications folder, and re-launch. The error attached resulted.
Repeat, placing the program into the folder beside the old version, and re-launch - same result.

Revert to previous config by deleting the new .app object and renaming the old one back to ‘manager.app’ - relaunch successfully.

Incidentally, reference the original query and the targeted location for the .app object. The location -
Users/(username)/Applications carries the applications icon, and allows execution of (other) applications. You may care to point out that Manager requires to be in the ‘System’ applications folder, and not at user level.

I did not personally install version 20.5.46. But that version is now 8 versions old. Try downloading the current version and installing it. I just installed 20.5.54 on macOS 10.15.4, following the exact procedure in the Guide, and it works fine.

I also installed it in a user-level Applications folder. It works fine from there, too.

Thanks.
I’ doing the install to bring myself up to date. Since the 18.9. version, the Mac has been upgraded to Catalina, which has stricter security of course.

As I wrote, I tried a re-install exactly as per guide, including the systems Apps target folder, resulting in the SQL error message, as does each variant on install which I’ve tried.
I accept that it is a local issue, but I haven’t found information which would help.
Does Manager log anything as it initialises? - helpful messages in a log to indicate successful startup. database found. database opened. problem in file access? - anything like that, and if so, where do I look.

Thanks for the guidance - and thanks to the team for such a good product.

R

I don’t know anything about logs. I suspect the only ones available would be the macOS system logs, not program logs.

Re-reading this thread, I see you provided little information about exactly how you are opening the program: from the File menu, from the Recent Items submenu on the Apple menu, from an icon in the Dock, by double-clicking the app icon itself, etc.

Also, just when in the process does the error message appear? Do you get as far as the Businesses page and encounter it when selecting a business? Or does it happen at some earlier stage?

Good Afternoon.

Let’s begin all over again, for I’ve done some further tests this morning.

Starting with ‘Old Manager’ - whilst it initialises, The list of businesses page does not appear correctly until the window is expanded. Condensing the window leaves the list visible.
This is an old version though, so let’s leave that.

Clicking any business takes over 30 seconds for the front screen to appear. Clicking any option - Invoices, accounts, anything, appears to hang.
This seems to me to be some sort of retry happening in the background attemtpting to access the database.

Examining the raw content of a .manager database file shows what appears to be account names immediately followed by what i assume is an internal recordID, plus plenty of hex characters - all as I would anticipate, and suggesting that object security, at least, is normal - no locked objects or records, at least at system level.

Moving on to Now - 50 seconds before starting this reply.

Removed all Manager objects from the PC.
Downloaded version 20. current. Followed instructions. Expected query about running an object from the 'net. Program is installed in the system level Apps folder.
Click on Program using Finder.

A SQLite exception is immediately thrown (below) which shows what i now realise is the Manager version 20.5.60 - followed by diagnostics which says exception read only. This sounds like the function requesting but not having read/write authority - a possible consequence of Catalina’s security upgrade, so something to be tested for and reported at some point of the initialisation to prevent exhibiting such a dense error message to a user (who can’t do anything with it anyway apart from report it)

I took a sample from the program, which provides more diagnostic detail of what stage it had reached for anyone familiar with the internals of the program - also attached below.

I hope this helps.

A further thought - all error messages have been SQL oriented, and we know that manager works correctly on other machines, so this error is related to the configuration of this PC. Since last used, much time has gone by, and the config of the operating system has dramatically altered, and MySQL has been removed.
I had rather hoped that an entirely fresh install would resolve this, but not so.

Unless - does a new install seek out existing Manager files? Do I have to remove all existing files to get a totally clean new install to prove it working?

I see your message says you installed 20.5.54, whereas I believe I have 20.5.60 ??

I also see that in a folder called ‘MonoBundle’ is over 70Mb wish of .dll files. A touch surprising, but not impossible. It definitely came from the .dmg object downloaded.

What do you mean by this? Did you remove everything from your application data folder? If so, you just removed your accounting data. See Manage application data folder contents | Manager for background information on what is there.

Do you mean double-click? As in to launch the application?

Have you looked at your permissions for the application data folder?

What do you mean by this? Did you do anything with the application bundle itself?

Yes. All data is in the application data folder. (See link above.) Some of the files there will be recreated, if necessary. But business data will not.

Definitely not! See remarks above.

All of my accounting data is securely backed up. That’s the first rule of any such investigation - as I’ve you repeating on this forum. Given unwanted behaviour from an accounting system, it’s the first thing to do - even one unused for 1400 plus days on this box

Yes, as in 'launch the application and observe that the OS is initialising it by seeing the ‘halo’ appear around the icon. Avoid using an alias, as that introduces another set of variables - such as an alias to an apparently identical, but different, object.

Yes, first thing to look at. Shows my user profile with read/Write and all others as Read only. If Manager is running under an adopted authority, then we could expect symptoms such as we’re discussing.

The MySQl product was co-resident. If Manager had used any of its components (because they were found on installation) and subsequent upgrades do not check, then again, we would see failures. I mention it only because the precise underlying mechanism is not, as far as I’m aware, documented publicly

Then all is well as far as the test process is concerned.

Meantime, I have copied the backup files to another mac - also now running Catalina 10.15.4 and Manager 18.12.10
All accounts data files operate normally as expected. (This is the user’s normal workstation and has no reported issues)
This may indicate that the inconsistency between manager versions is more than the current version can handle, and if the program had been upgraded through all of your intermediate versions, with the database changes you make, then it would work.

I could test for this by literally remove all manager objects, making a clean install, and creating a new business. If it creates, then I have identified the issue, and we can turn attention to upgrading the data. That would apparently need a sequence of Manager updates between 18.12.10 to 20.5.60, which is the one downloaded this morning.

Thanks for the more detailed information. Understand one thing. I am not the developer. I am a forum moderator. I have knowledge of how to use the program, but not how it actually works. I have never seen the code.

Your idea of cleaning everything out and starting from scratch is good. If the problem is too big a gap between upgrades, @lubos will be able to convert your file. You won’t have to do incremental updates.

So first see if a clean installation launches. Then try to import a backup.

Update.

Removed everything, including data. Downloaded a fresh .dmg files.

Same results.

I’m out of diagnostic ideas now. Hate these sealed box programs (though I know why it’s a good idea. I always include diagnostic mode run time ability to provide some clues - even if it’s as daft as counting the number of times the screen flashes or the wheel spins at start up time.

I appreciate your situation - I’ve done that job. I also appreciate your skilful way of asking the ‘is it turned on and did you press the enter key’ type of question.

I have other jobs to be doing for a while…

Thanks again
R

I am out of ideas, too. @lubos will have to look into this.