Can't Open a Manager File directly

Hi,

I’ve just updated to the latest Manager version on Mac (Mac v10.15.3; Manager v20.2.27). I store my accounts as backup files in Google Drive (to enable access from multiple computers - docs are never open on 2 computers at once). I’ve been using Manager like this for close to 2 years without issue.

Now when I try to open a backup file, it says " The document “December 2019 Backup.manager” could not be opened. Manager cannot open files of this type. ".

I am able to import the backups and access the data in that way, but not open directly like I used to be able to. I’ve also tried importing it, and then creating a new backup to see if that backup will open, but it doesn’t either.

Anything I can do to resolve this?

Since you’ve started a new topic on this subject, I closed your previous one addressing the same issue to avoid splitting the discussion.

Can you provide a little more information on how you are trying to open the files in Google Drive? Are you bringing them onto your computer first, or trying to open them directly while in Google Drive. If the latter, I suspect Google’s storage regimen is viewing or handling them as something besides a .manager file while they are on Google Drive. The fact that you can import the backup successfully proves nothing is wrong with the file itself. This certainly would not be the first instance where Google interposes its own view of the universe on unsuspecting users.

I have Backup & Sync on my computers (windows & mac), the files are stored on my computers, so I usually just double click and it opens. I’ve tried putting a backup on my desktop and opening from there, same result. Also right clicked and selected open with Manager, same result.

This is more confusing. You first wrote that you stored the accounts on Google Drive. Now you write that you store them on your computers. What is stored where?

Understand that the Manager application calls a data file stored at the designated application data folder path visible under Preferences. If you want that data stored elsewhere, you should change the default path on all your computers to point to wherever you store it. Follow the guidance here: https://www.manager.io/guides/10348. If you do that on all your computers (I’m assuming you are using the desktop edition on all), they will all call the same file. Then you only need to make sure you update all computers at the same time, because the program won’t let you open a file that has been touched by a more recent version.

The routine you describe of making backups and opening them has a strong potential to lead to trouble, because, while the program will directly open a standalone file, there is no synchronization process. The business referenced on the Businesses page has a different data file than the backup you are opening.

Backup & Sync is Google Drive on your computer, just like One Drive or all the others - all my files are synced to my Mac, Windows, and my Android Phone. If I add, remove or change any file (not just manager) it reflects on all devices.

Yes I know that it calls a designated file, I don’t use that - If I just open manager, it says I have no businesses added. Thats is the way that works best for me.
I backed up a file, and placed the file in a google drive folder on my computer, which syncs to my windows computer. The folder is also a shared folder, accessible by 2 others (one of them uses Manager only very seldom if I ask them to look at something specific).

I’ve never had an issue with syncing, the latest version of that file reflects on whichever computer that file gets opened from.

From Manager’s point of view, what you describe should work. So I think any issue is on Google’s end. I don’t use it, so I have no insight to offer. I do hear, however, of continually increasing complications with Google products as they add security features. Perhaps some recent update on their end changed something.

Can’t be, I’ve got some other old backups that were stored in iCloud, it won’t open that either, except for importing it. I’ve imported, backed up onto desktop, that new desktop backup won’t open either.

I’ve just switched over to my windows, tried to open the file, and instead of saying it can’t open the file, its just asking me to import the business, with no other options. Never happened to me before. So it must be because of the new version? It worked fine on the v19. Is there a way to download an older version?

There is no source, because—as I said earlier—once the file has been touched by a newer version, it can’t be opened by the older version.

Not that I’m aware of. I save old installation files and maintain backups of old versions of my data files so can always go back. Not sure if that is possible with your backup strategy.

Firstly, Google Drive, One Drive and Dropbox are always folders on the local computer, they are alternate names for the folder “My Documents”, except these folders have a feature where they are automatically duplicated to the cloud so there is an off-site backup. The local computer never directly accesses the cloud version of a file. When starting a computer the local folder sync’s with the cloud backup and updates any changed files so that the local computer now only contains the latest version of a file.

Manager has two methods of opening a business, firstly opening the application and selecting from the home page, or secondly, opening the business directly by double clicking the file or right clicking the file and selecting open with Manager.

It appears from the commentary above and in another topic that the second method is no longer functioning. Both users have been using the second method satisfactorily, however, since they have updated to Manager Desktop version 20.2.27 that method no longer functions as they get a message to the effect “The document ???.manager could not be opened. Manager cannot open files of this type.”

However, if they open the application and then import that same file it works without an issue. One user updates monthly so the change has occurred in the past month. It has occurred on both Mac and Windows and using files from both Google Drive and iCloud.

Therefore, until there is clarification from the developer that there has been an actual design change in process, I will list this as a bug.

Separately, it is concerning that there is a number of users who are using back-up versions of their business files as their day to day business files. I use Manager via Dropbox on different computers and have NEVER opened a backup file yet.

2 Likes

@SheldonSwanepoel’s descriptions were not clear to me. As I said earlier, I don’t use Google, so am not familiar with it. But it is possible with other cloud services to open files directly from the cloud service rather than from a “synching” folder like DropBox. I assumed that is what was being done—hence my potential confusion.

After reading your post, @Brucanna, I think your interpretation of what @SheldonSwanepoel is doing is probably correct. So I did a test and can confirm that Manager no longer opens data files directly on a Mac. I tested with v20.2.26, so the bug was introduced with that version or earlier.

I can confirm this.
using 20.2.28 on windows.
The storage solution used does not matter, as i am using nextcloud which works exactly like google drive and dropbox as described earlier in this thread.

i just checked on my Windows 10 system running Manager 20.2.31
i have my Application Data folder and my backups folder both synced to GDrive. the .manager files do open but Manager wants to import it as a new business rather than showing the business data.

below is a screenshot of Manager when i opened my business file from the Application Data folder directly.

if i click on Import Business, the file is listed as a business and i can work with it normally.

I’ve recently updated to Version 20.2.71, and I am having the same issue. I have one file stored on dropbox, and another stored on a folder which Google Drive automatically syncs.

Both want to be imported into Manager locally.

What I need to know, is will the files in their original locations be kept up to date, or will I have to manually export backups on a regular basis to the cloud-backed up folders.

Thanks.

If you import those to work on them, then you’ll be editing the new locally stored imported version, not the version in your cloud. So if you want the cloud one up to date, you’ll need to export when you’re done editing, and replace it.

As pointed to by @Tut earlier in this thread, you’re better off changing where Manager stores local files, to store it on drop box or google drive. See https://www.manager.io/guides/10348
BUT, this will only help you if the cloud folders are only for you to access. If you store multiple businesses in Manager, and you share the same manager folder with someone through a cloud provider, both (or more) parties will have access to ALL businesses of each of the parties sharing that folder.

Guides still show this:

Any Manager business data file can be opened directly if the desktop edition is properly installed on a computer.

Rather than first launching Manager and selecting a business from the list of businesses in the Businesses tab, open the data file using the computer’s operating system features. This action will launch the Manager application; the business file will be active.

Thus, copies or backups of a business can be stored remotely, transmitted electronically, transported on portable media, and opened by accountants or coworkers who do not have access to your applications data folder. The business does not need to be imported into an application data folder.

will it be changed back to this ? helps a lot to quickly identify businesses !

I have the same problem as described by the users at the top.and this happened after updating to the new version 20.2.65. So is there any solution for this problem?? because I had to stop working on my business because of that bug.
Thank you in advance

No. That’s why this is in the bugs category.

No, you did not. Import the business from the backup file according to this Guide: https://www.manager.io/guides/8890. But you should also be able to access the business directly from the businesses page within the program, unless you took deliberate steps to remove it or change the path of the application data folder.

Thank you @Tut for your reply. will you be working on fixing this bug?

I’m not the developer and have nothing to do with software development. I’m a forum moderator, another user.