Manager crashes with macOS 11 (Big Sur)

For what it’s worth, this is my setup; I had/have Manager version 20.9.84 and 20.10.71, respectively and I have not experienced any trouble so far on Big Sur.

I tried the new update:

Process: ManagerDesktop [72651]
Path: /Applications/
Identifier: io.manager
Version: 20.10.71 (1)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: ManagerDesktop [72651]
User ID: 502

Date/Time: 2020-11-25 07:26:04.739 +0100
OS Version: macOS 11.0.1 (20B29)
Report Version: 12
Bridge OS Version: 5.0.1 (18P2561)
Anonymous UUID: ACE7448B-E3FF-5ACA-45C8-CD7D4EFE0F19

But it didn’t fix the problem for me.

Sorry for this bad news.
But, did it work for somebody else?

I was having the same error as Alistar – after upgrading to Big Sur 11.0.1 on my MacBook Air (2017), Manager does not open and gives the same error as Alistar described above.

Following this thread, I downloaded the most updated version of Manager (Mac | Manager), unzipped it (ManagerServer-Mac-x64), then opened Terminal and entered the command as suggested above (./ManagerServer), but the Terminal sais:
-bash: ./ManagerServer: No such file or directory

I also tried with:
chmod a+x ManagerServer
chmod: ManagerServer: No such file or directory

Then I downloaded the Manager version from the front page of in a classic way, I opened the programme, but when I opened the last backup from my company’s data (add business, import business), it sais:
This business database is not valid
Manager data is stored in SQLite database. However it appears the file you are attempting to open is not a SQLite database.

What am I doing wrong?
I’m really worried, as it seems I have tried everything by now – and I tried several times.
Thanks for any help!

If you can open Manager in Big Sur, you should not have to import your business. Your data file should still be in the same place as it was in your application data folder. The business should appear on the Businesses page when you first launch Manager.

Why did you try to import a backup of your business?

It’s because the earlier version of Manager did not open at all after I upgraded to Big Sur (the same error such as Alistar had – image in the discussion above). So I had to download the new version of Manager, but this does not open the backup file from the old version.
Is there a (older) version of Manager available which opens old backup file, which I could then convert to SQLite?

See this response from the developer in another thread:

Ignore the fact that the other thread was about the same problem in Windows. The point is that you need a version old enough to still include the conversion script.

Yes, thanks, I saw this thread as well and figured this could help, but I don’t know where I can find a place to download the older version such as 20.9.89 for mac. The link above is for Windows.

So I downloaded the 20.9.89 for mac (simply changed the name of the link above, from msi to dmg), installed it, but then another kind of error appeared when importing the backup dataset:

Interestingly, the previous attempts to import the backup file are still visible on the business page and when opening them, the old kind of error appears. Could this be a problem that replacing an old version with a new one does not actually erase all the files/data in the Applications folder? Anyone has any ideas? Thank you so much in advance.

Nothing ever erases any file in the application data folder. Those files are not the program. They are accounting data files for businesses and a few housekeeping files. See Manage application data folder contents | Manager to understand the application data folder.

Hello all

I switched to the cloud edition a couple of weeks ago.
I needed an account for an other person as well.
Because of this problem I moved this switch a little bit forwards :wink:

Thanks for all the help, for now…
I don’t need help anymore, because the cloud edition is working without any problem!

Hi all, i am having the same problem with Manager crashing on Big Sur and the “Problem report” is huge, maybe 100 pages.

With me is crashing by simply re-typing a customer address when creating a quote for example.

I am using the latest Manager version, 20.10.93

See below screenshots

Screen Shot 2020-12-23 at 10.54.44 PM


@Inline, can you please be more specific about what triggers the crash? You wrote, “With me is crashing by simply re-typing a customer address….” Exactly when does the crash happen? As you type? When you click Create? Or at some other point?

Also, it looks like you are using dark mode. What happens if you use light mode? (I ask because, when dark mode was first introduced, there were some problems related specifically to it.)

1 Like

Hi @Tut, manager just crashed on me again just now and the way it triggered was when editing an existing sales quote.

  1. i selected search for an inventory item in an existing line;

  2. type the item name;

  3. hit enter to select the item; and

  4. Manager Crashed.

Yes, i had my mac appearance on Auto, but after this crash i changed to Light to see if the crash continues, since you mention that the problem could be related.


There is going to be fairly big internal change for Mac within Manager in a few days which will fix copy & pasting issue and there is a good chance it could fix this issue as well.

Hi @Tut and @lubos, just to update you guys since unfortunately with me it is happening often.

FYI, Manager just crashed again doing the exact same as below while my mac appearance being set to light mode.

Thanks @lubos for the update, appreciate if you would inform here once the release is up so i could update to the latest version to see if this problem is solved.

@lubos removed this topic from the bug category, so you should try v 20.10.94.

@Tut i have just installed V20.10.94 and on the first transaction (adding an inventory item) it crashed again and again when trying again, so it is happening more frequent now.

Here is how it happen:

1st time:

  1. in inventory item, i selected new inventory item;
  2. added item code, name, and description;
  3. chose custom income account;
  4. chose custom expense account and hit enter; and
  5. Manager Crashed.

2nd time:

  1. in inventory item, i selected new inventory item;
  2. added item code, name, and description (since it did not save due to crash);
  3. chose one custom field i have and hit enter and;
  4. Manager Crashed.

Now i have to save at every step an information is added or changed anywhere in Manager in order not to loose the work done.

@lubos could you please look at this.

Thank you.

@lubos here is an important information.

Since it is happening every single time with me, i did notice that what is triggering the crash is to HIT ENTER in any drop-down field.

I was able to add a new inventory item with complete details by selecting all drop-down fields with the mouse instead of hitting enter.

After saving the new inventory item, I did try to add a new item and on the first drop-down that i hit enter it crashed!

I hope this helps you to speed up the fix for this.

Thank you.

Happy New Year to you all!!!

Hi @lubos i update manager to the latest version (21.1.1) and thought that this crash problem would have been resolved, but it is still happening whenever “ENTER” key is used.

Any idea of when you will be able to look at this?

Thank you.

The internal change I’ve mentioned 2 weeks ago hasn’t made it into Manager yet. Should be sometime this week which should hopefully fix this issue.