Manager crashes with macOS 11 (Big Sur)

Hi,

I tried to make some invoices today, but, manager crashed time after time.
Tried to download from the website, (thought, maybe need an update)
Same result, manager crashes.

Is this a known problem?

I open Manager, try to make a new sales invoice,
When I give the name of the costumer Manager closes and Apple gives me a failure report.
(don’t know if you want the entire report, or only need a small piece of it.)

tried again, I passed the name, but with submitting a record it crashes again.

You need to provide information on version numbers Manager and OS

A copy of the screen with the error message and a copy of the screen that causes the error message would also help

This is the information with the version numbers and the error message
(I think you mean this part)

Process: Manager [36003]
Path: /Applications/Manager.app/Contents/MacOS/Manager
Identifier: io.manager
Version: 20.9.44 (1)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Manager [36003]
User ID: 502

Date/Time: 2020-11-17 21:35:27.139 +0100
OS Version: macOS 11.0.1 (20B29)
Report Version: 12
Bridge OS Version: 5.0.1 (18P2561)


The page in manager is: making a new sales invoice.
When I open the page, nothing goes wrong, no problem… But when I type the name of my costumer, and press enter (Manager normally get at this point the billing address) Manager crashes and closes down. than Mac OSX shows a error report, (the one that will be sent to apple automatically)

The first part of this report is shown above

@Aror, you implied that you had updated your software. But your Manager version is 100 updates behind. Download and update to the current version and see what happens.

Also, what hardware are you running (Model, date, etc.)

@Tut Sorry, wrong pictogram…

Process: ManagerDesktop [36792]
Path: /private/var/folders/*/Manager.app/Contents/MacOS/ManagerDesktop
Identifier: io.manager
Version: 20.10.64 (1)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: ManagerDesktop [36792]
User ID: 502

Date/Time: 2020-11-17 22:46:40.778 +0100
OS Version: macOS 11.0.1 (20B29)
Report Version: 12
Bridge OS Version: 5.0.1 (18P2561)
Anonymous UUID: ACE7448B-E3FF-5ACA-45C8-CD7D4EFE0F19

Sleep/Wake UUID: ED5F24DE-F250-4773-8E2B-F910983AA477

Time Awake Since Boot: 160000 seconds
Time Since Wake: 4300 seconds

System Integrity Protection: enabled

Notes: Translocated Process

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [36792]


Model: MacBookPro15,1, BootROM 1554.50.3.0.0 (iBridge: 18.16.12561.0.0,0), 6 processors, 6-Core Intel Core i7, 2,6 GHz, 16 GB, SMC
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, spdisplays_builtin
Graphics: kHW_AMDRadeonPro560XItem, Radeon Pro 560X, spdisplays_pcie_device, 4 GB
Memory Module: BANK 0/ChannelA-DIMM0, 8 GB, DDR4, 2400 MHz, Micron, 8ATF1G64HZ-2G6E1
Memory Module: BANK 2/ChannelB-DIMM0, 8 GB, DDR4, 2400 MHz, Micron, 8ATF1G64HZ-2G6E1
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x7BF), wl0: Sep 11 2020 16:57:49 version 9.30.440.2.32.5.61 FWID 01-129bddb
Bluetooth: Version 8.0.1f5, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.1 Bus
USB Device: USB 2.0 Hub
USB Device: Backup+ Hub
USB Device: Apple Watch Magnetic Charging Cable
USB Device: USB 2.0 BILLBOARD
USB Device: Backup+ Hub
USB Device: Backup+ Hub BK
USB Device: Apple T2 Bus
USB Device: Touch Bar Backlight
USB Device: Touch Bar Display
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Headset
USB Device: Ambient Light Sensor
USB Device: FaceTime HD Camera (Built-in)
USB Device: Apple T2 Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 47.4
Thunderbolt Bus: MacBook Pro, Apple Inc., 47.4

Could you try to install server edition on your Mac using this guide:

https://www.manager.io/server/installation/mac/

Then see if you get an error in Terminal window when creating an invoice?

sure, give me a minute :wink:

@lubos Help :wink:

Terminal:

MacBook-Pro-15inch:~ MacBookPro$ cd /Users/MacBookPro/Documents/ManagerServer-Mac-x64

MacBook-Pro-15inch:ManagerServer-Mac-x64 MacBookPro$ ./ManagerServer

-bash: ./ManagerServer: Permission denied

(I never work with Terminal, sorry)

Must be something unique with your setup @Aror - I can confirm running manager 20.10.65 with MacOs Big Sur creating invoices without issues.

@Aror before you launch

./ManagerServer

can you type

chmod a+x ManagerServer

This should fix permission denied issue.

I just upgraded to macOS Big Sur and I am not able to open my desktop version now. Attached is the error. Can someone please assist?

It worked @lubos.

I don’t get any errors in Terminal this time when I make an invoice.
Also Manager doesn’t shut down.

The only thing is that I had to push a lot of times ‘continue’ in system preferences because ‘… is not a known app supplier’
(dont know the correct english words used because I have my language set on Dutch)

But…
Nothing seems wrong in this version…

Getting this when I launch Terminal

Last login: Wed Nov 18 12:39:03 on ttys001

/Volumes/Manager/Manager.app/Contents/MacOS/Manager ; exit;

zainabf@Zainabs-MBP ~ % /Volumes/Manager/Manager.app/Contents/MacOS/Manager ; exit;

Could not find Microsoft.CSharp referenced by assembly CsvHelper, Version=8.0.0.0, Culture=neutral, PublicKeyToken=8c4959082be5c823.

@Alistar
Did you follow the text on the page?

You have to download the file, and after unzipping open it using Terminal.

Yes I downloaded and unzipped the folder. But cannot find .exe file. Below is screenshot to show how the folder opens up.

there is no exe file…
follow the instructions on the page.

(BTW, exe is a windows-file :wink: )

Sorry, doing it for the first time :neutral_face:

This is what i get in terminal:

Last login: Wed Nov 18 13:53:11 on ttys000

zainabf@Zainabs-MBP ~ % cd Downloads

zainabf@Zainabs-MBP Downloads % cd ManagerServer-Mac-x64

zainabf@Zainabs-MBP ManagerServer-Mac-x64 % ./ManagerServer

zsh: permission denied: ./ManagerServer

zainabf@Zainabs-MBP ManagerServer-Mac-x64 %

please let me know what am i doing wrong

You are doing fine…

I had the same… Lubos said:

After this I had to give a lot of permissions in system preferences because Apple doesn’t trust it :wink:

I gave all permissions and reached here. Am I going the right way? And what do i do next?

What does the Terminal screen say?