Manager quits when importing backup on Mac

I am using the cloud edtion but have to move to desktop. I have made backups. I opened the app on my Mac. When I tried to import the app quits. Please advise?

1 Like

Same here from desktop to desktop. Back up comes from 20.2.0 version and trying to import on the latest version on Mac Mojave.
Any suggestion anyone?

I can duplicate this. It is a bug and I have moved this topic to the bugs category.

Meanwhile, you can add the backup by copying or moving it directly into your application data folder. See Manage application data folder contents | Manager.

This problem could not be circumvented by removing less-standard characters or numbers from the file name, as has been suggested by some other threads on the forum. For example, XYZ.manager crashes the program upon import.

I am joining all of another thread to this topic, as it seems the problems are the same. Those posts follow immediately below.

I want to report a situation where we tried to migrate from Intel based app to M1 MacBook. What we did was:

  • backup business in the Intel machine
  • import business in the M1 machine
    via Google Drive

Unfortunately, the app in M1 will always crash when importing business.

Please kindly see how we can solve these issues soon.


What version of macOS?
What edition and version of Manager?
Exactly when in the process does the crash occur?
Any error message? If so, please post a screen shot.

What version of macOS?

What edition and version of Manager?

Exactly when in the process does the crash occur?
“import business” from the start page, then file selector comes up, after selecting the backup file and hit enter, the app exits.

Any error message? If so, please post a screen shot.
No error message, only the error log by OS.

Maybe worth
trying the latest versions and clicking on button not enter key

And renaming the import file to only used basic characters

1 Like

Yes, worked for me as well. thank you


I’m having the same issue on a M1 Mac (but have also tried importing it to an old MacBook Air with the same problem)

Importing the business or restoring from a backup both result in a crash - I’ve renamed the file to remove any characters other than spaces and letters, and also have clicked the open button rather than hitting the enter button.

The .manager file is stored on an iCloud Drive folder, however the problem is the same when the file is copied locally also.

I was running a slightly older version of manager on my dead laptop, maybe a month or two old.

The console crash report is below:

Process: ManagerDesktop [2526]
Path: /Applications/
Identifier: io.manager
Version: 21.1.12 (1)
Code Type: X86-64 (Translated)
Parent Process: ??? [1]
Responsible: ManagerDesktop [2526]
User ID: 501

Date/Time: 2021-01-08 15:34:38.783 +1100
OS Version: macOS 11.0.1 (20B29)
Report Version: 12
Anonymous UUID: F133653C-7A92-4908-8A0E-BE387A54D484

Time Awake Since Boot: 4300 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
terminating with uncaught exception of type NSException
abort() called
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘*** -[__NSPlaceholderArray initWithObjects:count:]: attempt to insert nil object from objects[0]’

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff2053c083 __exceptionPreprocess + 242
1 libobjc.A.dylib 0x00007fff2027417c objc_exception_throw + 48
2 CoreFoundation 0x00007fff205f0c82 _CFThrowFormattedException + 194
3 CoreFoundation 0x00007fff205eeea3 -[__NSPlaceholderArray initWithCapacity:].cold.1 + 0
4 CoreFoundation 0x00007fff20444f31 -[__NSPlaceholderArray initWithObjects:count:] + 154
5 CoreFoundation 0x00007fff2049eaa5 +[NSArray arrayWithObjects:count:] +

— truncated due to post length limit ----

I am using the latest version 21.1.11 and when I try to import the bank statement the system closes down with the message "manager quit unexpectedly’. Up till now, I have completed this step successfully on this computer.

Please search the forum before starting topics. This has been reported before.

Can you please try importing a backup to see if that also produces a crash. There is an active bug report on that, and this may be related.

Thank you tut. I have tried what you suggest but to no avail.

Please clarify what you mean. Did you try importing a backup? If so, did that cause a crash? Or did you import and no crash happened?

I tried importing a backup and Manager closed down.

I tried changing the name of a backup and importing it but the system still closed down.

Thank you. I will have joined this topic with the other I mentioned.

I had to rebuild my MAC and Time Machine due to corruption. MacOS Catalina 10.15.7.
Loading on all software again. Always did backups of Manager file.
Reloaded Manager, open it up, it does not contain my business - which I figured it wouldn’t.
I open Manager, click on Add Business - Import Business.
Every time I try the app crashes and I get the “Manager quit unexpectedly” error pop-up.

I am however able to open the same backup and save again as a backup, which I tried.
I need to add this business back into Manager. Please advise.

Just tried latest Manager 21.1.17 on macOS Big Sur 11.1, it crashes when importing business.

  1. create new business “demo”
  2. backup “demoxxx”
  3. import “demoxxx”
  4. crash

@aoboau, please search the forum before starting new topics. You reported a known bug. Your post was moved to this thread.

Thank you.