Importing Bank Tranactions

I am trying to import Bank Transactions but I keep getting this message: An item with the same key has already been added. How do I rectify this?

What version of the software are you using? And have you looked to see if the transactions have already been imported?

Double-check that the transaction doesn’t already exist. Maybe the first import worked and you didn’t notice?

It would be helpful if you could provide more information as well. For example, can you post a 2-3 line sample of the file you’re importing, a screenshot of the page you’re pasting it into, and a screenshot of the resulting error message?

Ignore this, see below (it’s not relevant): The other possibility is that you’re trying to do a Batch Update (not a Batch Create). If you intended to modify existing values, you need to paste the modified values back into the Batch Update form – do not use Batch Create in that situation.

Sorry to rain on your parade, @ShaneAU, but I think you are mistakenly writing about batch operations rather than importing bank statements. There is no pasting involved with importing.

Actually yes, you are correct. I shouldn’t answer questions near midnight :slight_smile: Have edited accordingly, thanks for pointing it out.

Hi Tut. I am working with Manager 17.9.50. I have checked and I cannot find any already imported bank transaction

OK. Are you following the procedure in this Guide exactly? https://www.manager.io/guides/9240.

I believe I did. I will try it again. Thanks Tut.

I still cannot find it. Where would it be?

@AMANDA, you need to help us help you. You are providing very little information and posting cryptic responses. Remember, no one on this forum can see your screen, knows anything about your computer system or what edition and version of Manager you are using, or what you have done to get to the position where you reached out for help unless you tell us. Let’s start at the beginning:

Post a screen shot of the error message. And tell us what operating system and what edition (desktop, server, or cloud).

It isn’t clear what you cannot find. Are you referring to the imported transactions? If not, what?

Sorry Tut. Yes, I am referring to the imported transactions. I cannot find them and yet, I keep getting the message that An item with the same key has already been added.

I am using desktop and the Manager 17.9.50 version.

Here is a screenshot

To make things easier to read, please enter your entire message before hitting the Reply button. And your screen shots can be included in the message with text.

Now, before you can do an import, you must select the bank account in the dropdown field named Bank account. Then, browse to the downloaded file that you got from your bank’s web site. Then click Next

But you have other problems. I see 97 journal entries, much more than any normal business would need, since you have no other transactions. That tells me you are misusing journal entries for other things.

You also don’t have the Customers or Sales Invoices tabs enabled. So unless you sell only over the counter to anonymous strangers, you aren’t doing any business. And even if that were so, you haven’t entered any bank transactions. But maybe that’s why you are trying to import a bank statement. Have you read these Guides:

https://www.manager.io/guides/8865
https://www.manager.io/guides/7018
https://www.manager.io/guides/7178
https://www.manager.io/guides/7820
https://www.manager.io/guides/9820

Thanks. I did select a bank account and browsed and selected the statement I wanted to import and got the above message as already stated.

You need to look in those 97 journal entries.

Hi @AMANDA,

Since the screenshot has been deleted, it’s difficult to follow along.

Could the screenshot be re-posted?

HI. I follow the guide to import the bank transaction. here is a screenshot.

However, after I have clicked NEXT, the below comes up

@AMANDA, you are making it more difficult to help you. Your most recent screen shots are obviously either:

  • From a different business with the same name and an entirely different group of tabs enabled, or
  • From the same business with all prior 97 transactions deleted.

You cannot change what you are showing and expect others to follow along. So what is the real situation? What did you do?

Hi Tut, I have given you the real situation, whether there are 97 Journals or not does not matter. Its still the same thing, that I cannot import bank statement. For your information it is the same business without the journals as you suggested it could be the reason that i cannot import the bank statement. So same business or not, how do I import bank? Main thing is that it isn’t working.