Firefox Backup

Not sure how it happened but I have three Manager backups showing in Firefox, if I try to open any of then a message appears to ask what program to open them with, but no applications suggested works, any ideas please

Every backup you make is a separate file. You don’t open them in a browser. Open them with the application.

Further to my initial query, all my Manager backups are now saving as and adobe Acrobat file, I just created another manager back up file in Desktop but this has also saved as an Adobe PDF which Manager can’t open. any suggestions would be greatly appreciated.

Could you please illustrate with some screenshots?

Short cut to Manager opens ok with current manager operating screen I’m working on, so I can still enter and save data but am concerned if I back up again the file won’t open, as previous message (there is no program associated with this file)

In windows show file extensions ( internet search how to do that if required).

That should show a valid manager backups end in .manager not.pdf

If so right click on a backup and choose open with… & select the manager program

Your backup isn’t saved as .pdf, it’s saved as .manager as it should.

The problem you are facing is that you tried to open the file directly and you must have chosen Acrobat by mistake and it got permanently associated with .manager type. This isn’t serious and it has no effect on the content of the backup file other than the icon.

You can still restore your backup as is by following this guide:

For instructions to change the file association back to Manager you can see the following webpage – though this would not change anything other than the icon since you can’t open .manager files by double clicking them anyways.

Your suggestions are appreciated, however I have tried all of them to no avail, Manager seems not to appear in apps, and when ‘open with’ is tried the same message appears, see attached SS. When ‘choose another program’ is tried no manager ikon appears

This proves Manager is installed on your computer, whether you can find it or not. The fact that it does not show up in the Open with menu means you incorrectly installed the program in some place of your own choosing instead of letting the installer put it where expected.

There is absolutely no risk in making another backup, because your data file will not be touched by the backup process. (Besides, you already cannot open backups, so why do you care if you create another unusable backup?) Be sure when you make the backup that the file name includes the .manager extension.

There is no conceivable way, as @Ealfardan already said, for the program to create a backup as a PDF file. So the only possible explanation is that you somehow associated .manager files with the .pdf extension, as already diagnosed by both @Ealfardan and @Patch.

So…find the program and fix the extension association. Meanwhile, your data is safe.

@Acomec I don’t think we’re on the same page because you haven’t tried any of my suggestions :slightly_smiling_face:

I say this because you still insist on trying to open the file directly either by double click or pressing Enter or using “Open with” because that’s not how you restore a backup.

To do that you need to follow the guides. This is a link to the specific section on Importing or Restoring from Backups

Also, your file is definitely a .manager like it says in the screenshot provided by you earlier.

See the yellow highlight next to the file, it says MANAGER file. So that’s good to know.

As for the file association issue, if Manager is in fact installed then you will be able to locate it in the Settings/Control Panel of Windows. If, however, you want to reset using “Open with”, you will have to manually search for the application file. This is a limitation of Windows, unfortunately.

But as I said earlier, file association is not necessary at all.

@Acomec try importing/restoring your file without changing the file association and the solution will become clearer.

I’m assuming you have installed Manager with default settings.
First of all you need to set File Explorer to show hidden files and show extensions. (can be turned off again later)
Once you right click on the file and get the ‘Open With’ prompt tick the ‘always open with this app’ and select ‘Choose another App’, choose ‘moreApps’.
Scroll down to ‘choose another App on this PC’.
Navigate to C:\users\jobyn\AppData\Roaming\Manager
Select Manager Desktop.exe.


‘Choose another app’ > ‘more apps’ does provide a list of several other apps (10) but none are able to open the file

Maybe I should remove and re-install Manager?

Follow this guide Backup, restore, import, and transfer businesses | Manager
In particular the import business part

No, you should read @VACUUMDOG 's post and follow the instructions. I don’t understand why you aren’t doing that.

However, the simplest way is to open a .manager file from within Manager itself.

Many thanks to all for your suggestions. I have tried to restore as per advice and instructions but to no avail. All seems to be same as before, please see error message attached

Did you follow the instructions in the error message?

If you want help then please use much better resolution screen captures as it is impossible to read the error message content. Also why do you show two windows. Just capture the relevant ones at better resolution so we can read the content.

I assume two screens are captured as he has two monitors.
The solution is to

  • paste the screen capture in Windows “Paint”
  • Choose the selection tool and select the area of interest
  • Click on the “Crop” tool
  • Redact any private information (if required)
  • Save the file as a jpeg
  • attach this file to the forum post

@Acomec You cannot install/repair an installation while the program is in use. That’s why you get the error because the installer is trying to change a file already in use.

Now what you need to do is to close Manager and repair the installation again–just in case the failed repair attempt missed something up.

However, repair and installation were not required in the first place–but now they might be.

Anyway, back to your original issue.

Your issue was not with Manager, but it was with your Windows configuration. To illustrate what went wrong, I recreated the entire scenario from scratch:

Illustration 1–Recreating Original Issue

Set association Acrobat

And just in case the repair/reinstall doesn’t fix your issue, here’s a detailed step by step instruction on how to set the file association back to Manager.

Illustration 2–Solution

Set association back to Manager


  1. Use Windows Search to locate Manager > Right Click and then Open File Location

  2. In Manager file location, locate Manager file > Right Click and then go to Properties

  3. From Properties > Copy the value inside Target field.

  4. Go back to your Backup file > Right Click > Open with > Choose another app

  5. Check the box that says :ballot_box_with_check: Always use this app to open .manager files

  6. Go to the end of the apps menu > Click More apps > go to the end again and click Look for another app on this PC and a file dialogue prompt will appear

  7. Paste whatever value copied from Step 3 into the field File name > then Click Open

I hope this fixes your issue

1 Like