Taking over management of an account

I have just taken over as Treasurer of a not-for-profit organisation. The previous users have used Manager to manage their accounts. The previous Treasurer gave me a USB stick with all the files on it after showing me the basics on his computer. After I downloaded the Manager App, I inserted the USB stick into my computer. When the folder opens all the files show as PDF files. I opened Manager and chose Import a Business. I was able to select the file (PDF) from the USB stick and the app recognised that as a Manager file and created the business. In the App, I can then see transactions up to 2018, even though there should be data to current date. I cannot use any of the files on the USB stick because it wants to open them in Adobe Reader, although Adobe doesn’t recognise them. None of this makes any sense to me and goes against everything that I understand about computer files (especially considering that when the USB stick was put back into the other computer, the files were recognised as Manager files and could be accessed). I have tried uninstalling the app and reinstalling it but the same things happens. Any thoughts?

See my post at I have problem opening my manager io on my computer - #7 by Joc

Your file association in your computer for .manager files should be set to the Manager Application. If a business imports as you did and it does not have recent entries then this was never entered in the file you imported and you should ask for a more recent updated version from the previous users.

I tried to download the attached Manager from my email but this box appeared. Please advise what to do next.

Thank you

You provide no information about what this is related to. You certainly did not download the Manager application as an email attachment. It is simply too large. Yet your most recent error message indicates you tried to open an application, not an attachment. So you cannot have done what you say you did.

As a guess, it appears you may have installed a version of Manager for the wrong operating system.

Everything you have revealed suggests problems with your computer and its setup, not with Manager. If you do not personally have the skills to resolve them, you need to arrange qualified technical support.

1 Like

In addition to what @Tut said, you can download the program from the official download link and avoid all unnecessary complications.

Here’s the official download page:

Note: You should keep an additional copy of the data files or backups when installing new instances of Manager, just in case the data file and the software version aren’t compatible.

In case you needed to install an older version of the software, you can visit this page:

I just download this https://www.manager.io/download/ the link that you sent me , but the when I open the document the pop up box shows this

What should I do next? I will really appreciate your help.

Thank you Ealfardan

As I wrote earlier, all information suggests you installed the wrong version of Manager for your operating system. Since you are running Windows, make sure you install the 32 or 64 bit version to match your version of Windows.

On the download page Download | Manager Click on the blue hyperlink “alternative download”

see screenshot below.
Screenshot 2022-06-22 at 09.03.14

Hi Eko,

Thank you for your email. I have tried what you just suggested to click the blue hyperlink ( alternative download) then shis box below appeared

which one of these below should I click? Modify, Repair or Remove?

Please advice

Thank you

From your last screenshot, it appears that you haven’t installed the Manager software since the file you are trying to run doesn’t have the Manager logo yet.

What you need to do is:

  • Download the Manager installer
  • Go to your downloads location and run the installer you just downloaded
  • When running the downloaded installer, you maybe prompted to allow the installer to make changes on your computer. Click YES.
  • After finishing the installation you can follow the steps in this guide to import the files you are trying to run:
    Backup, restore, import, and transfer businesses | Manager

All windows users need to be aware that if your computer comes equipped with windows S you cannot install anything but Micro$oft apps/programs.
However, you can get out of it

1 Like