Email Set up

I am trying to set my email, but I receive "Client does not have permission to submit mail to this server. The server response was: TLS currently unavailable. How do I fix this?

I have read through the user guide, but can’t seem to solve the problem, please assist.

Read the Guide about troubleshooting email. Follow all relevant links. If your questions are not answered, furnish all information listed in the Guide.

This is my screen, I have paid an it specialist to come out to have a look and still no success as he is stuck exactly where I am struck. I have been a customer 5 years of manager and would like some real assistance to resolve this problem please.

There are two observations:

  1. It is very unusual that the SMTP server (smtp.afrihost.co.za) would have users with another domain name (graciousbakers.co.za)
  2. Did you try to enable (click on) Do not verify TLS certificate as your error message was “TLS currently unavailable”
1 Like

I tried that as well. I still have an error message.

Afrihost is an service provider and administrates my domain “graciousbakers.co.za”

It seems that afrihost.co.za only allows smtp via port 25 so change 587 (which is STARTLS (tLS)) to 25 and try again. You do not have to enable “Do not verify TLS certificate”

@Lizrau are these the identical email settings which you have in your email client, like Outlook?

It’s a while since I’ve used afrihost, but usually, soon after a domain is registered, the mail servers switch to your domain, and not a generic ISP domain. You’d expect something like mail.graciousbakers.co.za or smtp.graciousbakers.co.za as your smtp server. Actually, it might be worth sending afrihost a message to confirm the details…

A while ago I gave up on this problem, but now I have to have it resolved or change to a different system.

I did contact Afrihost to ensured me everything is correct, but I will contact them again. Our email account runs through Gmail. When I follow the guidelines I do not get to the 2 step verification and can’t get an app password they are referring to. I did turn on the access for less secure apps. So I really do not know how to get to that app passwords they are explaining.



Do you have 2-Step Verification turned on for your Google account? The app password needs that first.

I recently had to get an app password for Gmail to link Thunderbird for a while and followed the instructions here: Sign in with App Passwords - Google Account Help

It has a link for 2-step verification and further instructions. You’ll (hopefully) eventually get a one-off password to link the app to your Gmail account.

Another thought. Although you run your emails through Gmail, you ought to be able to send the Manager emails directly via your smtp server and not via Gmail, since you’re sending yourself a copy you’ll have a record of the mails on Gmail.

That doesn’t explain why you haven’t been able to do that so far.

This is all a bit confusing. You first mentioned that your email was run with your hosting company Afrihost but now it is with Gmail. That also means you should use the instructions at Google Gmail | Manager (note SMTP server is smtp.gmail.com and port to 587 in addition to ensuring 2FA as described in the link.

There is no options on my screen to do as instructed. When I click on signing in to google it directs me to a page to change my password only. Please see snippets of my screens I see under security tab.



Afrihost: Understanding email error messages | Help Centre

  • SMTP / Outgoing server uses port 465 with SSL secure encryption and port 587 or 25 for non-SSL encryption.
  • SMTP / Outgoing server name should be mail.yourdomainname.co.za or use the name of the server.

I contacted Afrihost and they said I must use. mail.graciousbakers.co.za, however error persists and they now say they can’t help I must contact google. So I am just going in circles.

I think also test by unticking “Do not verify TLS certificate”

Edit: and also re-test with port 25 (unticked and ticked), now that they’ve given you the correct server.

I have tried all the options 25, tick, untick and still I get the same error message.

The solution is indicated in the guide mentioned by @eko in post # 11, which you haven’t even read.

@Mark I did read @eko’s response. I actually have spent days and many hours on this problem. Unfortunately I am not an IT specialist. Even the It specialist I paid to come and resolve this problem could not.

  1. I Showed screen shot that under my security tab there is no 2 way verification, so I can not access the app password and I am unable to understand why there is no such option.

  2. The second link on smtp does not load by me. I have tried to contact google, but it has proven to be rather tricky. I have read through pages on the smtp, but unfortunately the IT jargon is rather overwhelming.

I was hoping for a solution. My domain graciosubakers.co.za is with the service provider afrihost, but my emails are set up through gmail. If I need to change this I will as I have to be able to sent emails.

So I am not sure what I am missing or how I am not even reading the solution.

From one of your screenshots see below it recommends actions to Protect your account. Can you click on Protect your account and show a screenshot of the resulting screen.

You should get a screen where it allows you to setuo 2FA (2-Step Verification using your phione) as per my screenshot below:

Once enabled follow the instructions on: Google Gmail | Manager