Manager 17.1.40 for Mac crashes when printing

Almost every time I try to print Manager will crash. I click Print, then the macOS print dialog window comes up, then it beachballs and crashes. I fill out an Apple crash report and restart. Tested with sales invoices. Haven’t tried printing reports. Export to PDF works fine, so for now I am exporting to PDF and printing those with the Preview app.

Three questions:

  1. What version of macOS? (This really should not matter.)
  2. Are you attempting to scale the printed output in the macOS dialog box? If you use anything other than the default 100% scale factor, the program will crash.
  3. Do you get any error message? If so, please post a screen shot of it.

macOS 10.12.3. I am not trying to use scaling, I’ll try printing when I get back to the office and make sure it isn’t turned on. I get no error message from Manager. The system print dialog opens, beachballs, and then the app finally disappears and is replaced with the Apple crash report window.

At office. Tried printing again today. For the first four time I tried it, browsing through any system print dialog options triggers a crash. Finally I opened the system print dialog, canceled out, and did that several times. Now Manager seems to print without crashing, although I do notice some brief graphical glitches in the document preview when switching options or presets.

I think those are caused by the system, not Manager. You might notice them when printing from other applications, too, depending on how applications handle printing, that is, by using the built-in drivers or using their own.

I experimented with the preview pane in Safari. Making adjustments causes the preview sheet to go white briefly while (I assume) the preview is re-rendered. This is different than in Manager when the preview sheet briefly has page elements misplaced and out of alignment for 1 second or so. But as you stated, perhaps it’s an Apple issue.

What you describe for Manager is just the software readjusting margins, column widths, etc. It does not represent any software bug.

OK, great! I’ll post again if the crash while printing occurs again. It happened continuously this morning, but this afternoon has been fine.

This is almost certainly a problem with your computer or printer driver. No other Mac user has reported this specific behavior.

Noted, thanks. When I get time, I’ll test things on my other Mac at home.

Yep, same problem for me. I just print to pdf then print from that.

@ProDev, since you are only the 2nd person to report this specific problem, and I can’t reproduce it, I am curious what printer you are using and whether you have a driver written by the printer manufacturer (such as an HP Solutions software that controls a bunch of auxiliary apps) or are using the built-in macOS driver for your printer.

Sorry, but I have not yet tested on my other Mac. Printing has been working fine on my main Mac with no crashes for the last 10 days or so, and printing has never caused a crash on my Windows 10 PC. My Mac has an uptime of 25 days, so restarting the OS wasn’t a factor. I’m using a Brother MFC-J470DW at my office. I’m not using any special drivers, just whatever macOS chose when I added the printer.

Im having the same problem, although it worked momentarily a minute ago but has now stopped working again.

@FilemanAntiques, you need to be more specific, especially since things previously worked properly. Provide details on edition, version, operating system, and exactly what led to the problem, as well as exactly what you meant by “stopped working.”

Firstly, thanks for this software and support!

I’m also having the issue.
Im running Manager 16.12.42, and when I go to print, or print as PDF (not your direct pdf option) I get a crash. Either with no warning, or yesterday it asked me to download Developer Tools (XCode) which I did. Now it asks for a password to let “Developer Tools Access” to continue debugging. When I give that it still crashes with no error code.

I have the text for the report to apple if you would like it sent another way, but I’m not sure I’m wise to post all of that detail here.
I am using OS 10.12.3.

Update your software and see if the problem persists. You are close to 100 updates behind.

1 Like

Hi again,

Updated the app and the same thing is happening.

Let me know if you would like any further info!
I have found a work around for the moment, but it’s probably going to crop up with others. Thanks.

There is not much that can be done about Print button if it doesn’t work. Use PDF button instead.

If PDF button doesn’t work and you are using the latest version, then you can email your accounting file to and specify what exactly you are trying to print (which invoice, report etc.) and what error do you get.

1 Like

PDF button works, so that’s my way forward.
Thanks for your help.