Viewing STPR closes Manager


When I go to view STPR , Manager quits .
Editing and creating new report is fine .
Latest version just installed .

Can anybody help ?


Not without more information as it works for me, so I can’t reproduce your error.

  • What is the actual version(s) of manager you have reproduces this fault with?

  • Have you reinstalled the localisation or updated it?

  • does it occur with backup versions of your data & program file?

  • Screen shots leading up to the fault

  • Are all of the prior values reasonable or has an error visible?

  • Screen shot of what happens

  • What OS you are using.

  • Can you reproduce it in another new test business.

Hi , thanks for responding

In order

1 . Latest version of Manager .
2 . Localizations reinstalled
3 . To test back up versions would mean opening them in a test Business , is this correct ?
4 . I can create new STPR and can edit old and new but just can’t view , so not sure what screen shot to show you .
5 . Am not getting any error messages
6 . Manager just closes when I click view so I can’t provide a screen shot there .
7 . OS is Mac 10:15:2
8 . Does this mean creating a new business and importing backed up data .

BTW , when viewing STPR in cloud version it is very slow to download and the file is zipped and I can’t open it .


No one else is reporting this problems so it is likely to be something you are doing or something wrong with your setup.

No one else can see what you are doing. As you have been having trouble finding a solution it is important to not filter what you are seeing based on your understanding of what it should be, as that will only get us to your level of understanding (which has not solved your problem in 3 weeks).

To bluntly paraphrase what you have said is: I’m using Mac 10.15.2. I think I’m doing everything correctly but manager closes when I try to do STPR. Fix my problem.

Sorry I can’t help you with this level of information. You will need to spend time making screen shots, testing a simplified system, and changing a component at a time.

Yes , a fair and thoughtful appraisal of where I am at , thankyou .
So I will continue on with testing different approaches and at the same time put my mind to how I can provide some useful evidence in order to be helped .

Saying I am using the “latest version” of Manager is pointless - please the number of the version you are using

This is what I have discovered so far .
The test business I have loaded with the barest minimum of inputs does not close down when I go to view a STPR .

Then I would suspect Manager error checking is not picking up an anomaly in one of your staff details. Looking most closely at staff details which have been recently updated maybe fruitful

Hmm … I have entered staff details into the test business exactly the same as problem business and STPR still opens to view in test business .
The PAYG payment summary - individual non business also closes the program .
I suppose because the tw reports are linked ?
So now I have created payslip items , recurring payslips then STPR’s in test business and the reports are viewing ok .
Does this mean employee details are ok ?

They are different presentations of the same data. I suspect both procedures are passed the same data when called. Both failing suggests a problem with the data set passed ti both.


As well as being in the Applications folder , Manager has an icon in the side bar .
Is this as it should be , screen shot attached .

The icon in the sidebar is the mounted disk image from the download. It contains the application, which should have been dragged to the Applications folder. That mounted disk can be dragged to the Trash to unmount it. You should not be trying to open the application it contains. You should open the application in the Applications folder.

Yes , I do open Manager from the applications folder or from the dock more exactly.
And as suggested I tried to move the icon from the sidebar to the bin but got a message saying not possible because it can’t be deleted . Hmmm … anyway , I am asking these things in the vain hope it might be related to the difficulty I am having viewing the STPR .

You cannot move the icon from the sidebar to the trash. You have to move the mounted disk on your desktop to the trash.

But all of this is completely unrelated to the report closing the program. So forget about that issue as a source of the problem. Personally, I have no experience using the STPR, but @patch does.

If there was a problem with data passed to both , then maybe I have no option but to delete all of the STPR reports and redo them ? … Arghhh !!!
Not such a big deal really .
Actually probably won’t work as even the new ones I create already can’t be viewed .

Got it , moved to bin and definitely didn’t change anything .

Please post screenshots showing what you can actually see including:

  • report definition screen

  • What you see when you view the report

  • What you see when you try to save the csv file

Depending on what these show more screen shots are likely to be required later.

Do you have old back ups of your Manager data file, in particular from when it worked in the past. If you import an old backup (leaving the old date in the name so you can identify the old data file), does that also produce the error / Manager quitting?

Clipping screen shots to show just the Manager window makes them more readable. Programs which do clipping also enable you to paint over private information. I’m not sure how best to do it on a Mac, @Tut would know better than me.

In order …
1 Not sure what report definition screen is but sounds like pop up when there is an error . So no error message . Program just closes .
2 When I go to view the report the program just closes so nothing to see .
3 Not able to save the csv file because I only have that option if I can view the file .

To summarise - I can create and see the report with no csv option . Then when returning to view again and save as csv the program closes .
But still have edit option .

Yes , I have imported a backup from prior to the problem but no help there .
And should be able to manage the editing of screen shots now you have informed me as to what appropriate standard procedure

Thankyou , AB

This is an example of a report definition screen for STP
10 STP Report definition
What does the one you have been using look like?

It should show something like (note redacted to obscure confidential information - which author has to check is appropriate)

That is the case if you do not tell us what happens when you try.
If you tell us it may help. Does the old backup data file with your current program installation work properly and produce the cvs file or does the program quit. This test tell us if you have a program installation problem or a data file problem.

Report definition screen shot attached .
Also Payslip Totals per Item and Employee with what I consider to be private information blacked out . This screen is what I see when I create the report and once having closed this am not able to view the actual STPR .
The year to date totals seem correct with this report but the pay week totals are twice what they should be . This is the same in my TEST Business but doesn’t seem to create any viewing problems with the actual STPR .
Yes , when I do import a previous back up into the program it closes when I go to view the STPR .

Hmmm … I have just discovered I can create and view an STPR for a period prior to any payslips being issued but when it is is linked to a payslip with totals the problem returns . So I am scrutinising this area .