TPAR report transformation bug

Set up TPAR as per above guide. The report is showing the correct amount in the Total GST column but the Gross amount paid column is incorrectly showing the same as the Total GST column.


@sparky, the small portion of the TPAR you show suggests that you might be entering transactions incorrectly. But your situation cannot be analyzed by looking at the report. Post a screen shot of the Edit screen of a purchase invoice for one of the suppliers included on the report.

@Tut @lubos - Screenshot of the Edit screen of a purchase invoice for one of the suppliers on the report as requested and also the Taxable Purchases by Supplier report which is correct.


OK, @sparky. You have shown a mostly obscured purchase invoice #1102. This raises the first question: Is the GST 10% tax code you applied the one you imported using the localization feature, or a previously activated built-in one, or a custom code? If it is one of the first two options, it is being used correctly. If it is the third option (custom tax code), the TPAR will not pick it up.

The second question is, what do you see when you drill down in the Taxable Purchases by Supplier report for this supplier? In other words, what makes up the 2,614.52 under Tax on Purchases?

The GST 10% tax code is the previously activated built-in code.
Drill down of report is 2 pages of payments to this supplier over the period of the report. (Small excerpt shown.)

Perhaps the error is occurring in the actual coding of the TPAR report with the ‘Gross amount paid’ column?

OK, @sparky, it looks like you’re doing everything correctly. I finally built myself an Australian test company, and I can reproduce this error. I’ve moved your first post on this topic and all our exchanges to a new topic for better visibility.

@lubos, this appears to be a bug. It may have crept in when you were adjusting the TPAR form. (I noticed some minor text alignment changes. Perhaps there were other changes, too?)

Thanks @Tut

@sparky, you can import new version of the report which should be fixed now.


Also, you will need to be on the latest version (19.6.52) because I’ve added some improvements to Manager itself to support this report.

Thank you @lubos. It is now fixed.