Themes not printing correctly on Windows machines

I am trying to use an inbuild custom theme to print with but it prints without colour. If I create a PDF file all the colours are there. I am using the inbuilt green theme. I have set the default them for the invoice. Is there another option that I should be setting please?

There is no option to set. Are you sure you don’t have a printer or ink problem? This could be something as simple as having selected black and white or grayscale printing in the print dialog box.

No, definitely haven’t set greyscale or black only in the printer settings.
I have tried printing something else and it prints fine

Let’s clarify the situation. Are you printing the PDF created from the View screen? Or are you printing directly with the Print button?

Also, does this happen with any other theme? (You can activate one for a test and deactivate it afterwards.)

Finally, exactly which theme are you mentioning? There are several with green in their names.

To clarify:-
Printing directly from the print button.
I think I have worked out what is happening and perhaps I may be causing the problem inadvertently. My quotes have the Smooth Yellow default theme whereas my invoices have the Smooth Green theme. If I copy to a new sales invoice within the existing quote and then try to print it after saving it, this is when it appears to not print correctly. Perhaps I have to have a default them throughout, but I was hoping to create a colour theme like this so that I could immediately differentiate visually this way. It seems to be OK visually on screen but when I try to print it only prints a thin coloured line under the Invoice block rather than a full colour block of green

That should not be required. Form defaults for custom themes override a source transaction’s theme when I try this with different themes.

Try this experiment:

  1. Copy a quote in one theme to a new sales invoice in a different theme. Based on what you’ve said, this should be your normal practice.
  2. Before creating the new sales invoice, verify that the desired default theme was used.
  3. Create the new sales invoice.
  4. Navigate to a different page in Manager.
  5. Return to the sales invoice and Print. See if it prints properly.

If Step #5 is successful, there is some issue with updating the record in the database. And that would be a bug. Since I cannot duplicate it, this might possibly be dependent on your operating system or something else.

What operating system, edition (desktop, server, or cloud), and version number are you using?

I have followed your steps as above and it does in fact not print correctly. All I get is an underline below the word Invoice instead of it being enclosed in a complete green box.
Operating system is Windows 10 64bit. I am using the desktop version and it is 19.2.85

I am having a similar problem with payslips. I didn’t have time to investigate so went back to using a plain theme.

I will investigate my problem in more depth - I was assuming that it was a problem with my Windows 10 printer driver but perhaps it isn’t

I use Windows 10 64bit and desktop version 19.2.84

This looks like a Windows thing. I cannot reproduce it on my Mac, doing exactly what you say you are, with the same version and desktop edition.

OK, so where do we go from here?

@lubos @Tut
i can confirm this happens to the default color themes and my custom theme as well.
Windows 10 x64

looks like this has been an issue from older versions as i am not on the latest. never used the Print button so i cannot confirm when this issue appeared initially.

below is the default Smooth Navy theme displayed in Manager.

below is what we get when Print button is used.

i selected the Microsoft Print to PDF option but as others have confirmed it happens with actual printers too.

Yes, that is EXACTLY what I get. Glad I’m not the only one

yes there is some bug as i tried and get same result as @sharpdrivetek mentioned in his reply.
i m also using win10 64bit

I have put this into the bugs category and changed the title.

This is not a bug in Manager. It’s basically a “feature” of Internet Explorer which Manager is using on Windows when printing using Print button.

Basically, you need to open Internet Explorer and change the settings so the printing prints “background images and colors”. By default it doesn’t to save the ink.

Here are some tutorials how to change the settings.

@lubos in future is there any possibility to remove this Manager dependency of optional applications in Windows?

as you very well know, majority of Windows users seldom use IE. even Microsoft themselves have provided an alternate browser called EDGE.
this makes IE an optional application in Windows. making Manager dependent on IE settings will force users to have IE installed on their computer.

I personally have uninstalled IE from my computer and i am unable to find an alternate solution to this problem. the only option at present would be to download and install IE again just to use the Print function in Manager.

Removing IE dependency on Windows would increase the size of the app from 13 MB to 60 MB. It’s a trade-off.

Maybe I can help with this problem.
You do show invoices, just one, click the right mouse on the display, then select print preview.
Then select page setup (gear image), sign Print backgroung colors and images.
Please try.


@stanisk_welly that suggestion works perfectly. thank you for reminding me of this. i had completely forgot the same.
also, this option needs to be set only once. so the users can print directly using the Print option in Manager after setting the same.

yes the solution works perfectly fine.