SQLite Exception Could not open database file

Hi, I am hoping someone can help me.

the HC on my Mac failed recently during the upgrade to Catalina. As I am an idiot, I had no Time Machine back up, or anything, and had not backed up the Manager File for some time.

Poor fool me.

Luckily I had a friend who is a service engineer, and he was able to get it operating and recover previous backups from the failed drive. he also set up time machine, so don’t have to go through this process again.

As there was no programs installed, I downloaded the installation file and fired it up. This was mainly because I couldn’t see how to install a back up file, and I wanted to check first. I got to the create business page, and then shut it down, and moved the dmg file to Applications (I thought It should try to do this before starting but it didn’t) I tried again, and bought up the attached popup. I deleted the file and redownloaded again, and got this same file. I then got CCleaner and ran that, in order to remove registry links, and tried again. still no joy.

As such, I can get manager to work on my computer. the back up I have will require the reentry of probably 100 documents. I don’t mind, but I can’t even get it to open.

Looking at the file, it is looking for a file called 00000000000000000000000.manager, or similar. my understanding is that it creates this file when it is first initiated, and is like a configuration file. I deleted this and every other file I had on my computer (except the back ups) with the extension.manager, and tried again, but still get this same pop-up, referring to SQLite.

I see there are similar issues in the forum, but are a few years old, and seem to be linux related, not seem to have the same behaviour as described here

update: I found some cached files under io.manager. I cleared these, but still won’t load

I have the same problem

First, you need to read two Guides:

You have several major issues:

  • 00000000000000000000000.manager is an index file and contains no accounting data. Don’t waste time trying to open it.
  • On your Mac, the application data folder is hidden. The program is working with the hidden folder by default, not anything you installed from your data recovery effort. See the first Guide above for more information.
  • You don’t install the disk image file. Again, see the first link above.

I strongly recommend that you stop randomly trying things, such as blindly deleting files and running cleaning programs, until you understand what you are trying to do and what any other programs might damage.

Looking at what file? And how are you determining that it is looking for the index file?

looking at the image as sent in the original post, it is looking for this 00000000000000000 file in a specific location.

as the program has not installed but has left residual bits in inaccessible places, given a lack of information as to how to proceed, I have been trying to revert to a situation where I can download the programmed ave it run. until then, I can stare mournfully at my computer or try things.

Your advice, as informed as it is, does not give me any means to resolve the problem. 8394 assumes that the program exists in the application folder, which it doesn’t, and I have essentially followed the process in 7116. clearly, what is needed is the the step to resolve this, if the error, as posted in the image occurs.

perhaps, after rereading my post, and your response, it is not absolutely clear that I want to freshly install the program after removing whatever is causing the SQLite exception error. After that, I assume it will occur as per every other time I have installed it. as such my random deletions are about reverting to a condition where it has not previously heard of the program and will accept it openly.

Interesting. is this also on a Mac after a disk recovery, or just the same SQLite error. I am sure your common experience will add to the information to resolve this, if you can share further information on this

As a further update I again followed the 7116 guide prescriptively and got the same SQLite result.

While this guide clearly works in most circumstances, and has worked on all other occasions for me, in this instance, has not.

No, it does not. The program should be installed in the Applications folder. The application data folder referred to in that Guide is a hidden folder where the data files are stored. They are not the same thing.

I don’t know what you mean by “essentially.” You either followed the process exactly or you did not. If you did not, there is no way of telling what you might have done that is preventing success. Follow it exactly. Do not make the mistake of thinking you can move files around like you normally would on a Mac and put them wherever you want.

You say you want to go back to a condition equivalent to what you had before you ever installed Manager, then get back into operation. To do that, follow these steps:

  1. Drag the Manager icon from your Applications folder to the Trash. (The program contains no data and will be replaced when you reinstall it.
  2. Following the instructions in the first Guide above, find your hidden application data folder. You can also make it visible in the Finder by typing Command + Shift + . (that’s a period at the end). Move the entire folder to some safe location. (Your desktop will work.)
  3. Download and install the program per the first Guide above.
  4. Import your recovered file from wherever you stored it.

If that does not work, the recovered file is most likely damaged from your disk failure. Not every file salvaged in a recovery attempt is actually still usable.

Thank you for your continued help.

  1. I dragged the manager icon to the trash. this was after, as I said before prescriptively following the 7116 guide to install, and resulting in the same failure

  2. This is problematic, as I can not determine the location of the hidden application data folder, as I can not click on Preferences in the Menu Bar, as Managerer does not open, only the SQLite exception dialogue box comes up. the the top bar is only the heading Manager, with opens to reveal Services (which indicates a sub menu by the triangle symbol, but doesn’t open), and options to Hide Manager, Hide Others, or Quit Manger. Using Finder to find the files using the command, shift and fullstops keys, reveals no files with the extension .manager, hundreds of folders called data, none of which have been created since the computer was recovered, no folders or files called size, and one folder called trash, which contains previously deleted files, nothing to do with manager.

  3. did this and again same result with the Sqlite exception

  4. Again is problematic as the location to restore the files to is unknown.

sorry just noted your final comment.

the recovered file has not come into play. I can not install it the recovered file is on a separate drive which is physically disconnected (unplugged)

@Fakarwi, you have me confused, because you have given contradictory information. In your first post, you said you had reached the page for creating a business. That means the application launched. Now you say Manager will not open at all. You also said you had left backups on your computer. Now you say your recovered files are on a separate drive that is not even connected.

Let’s go back to basics. Assuming you have never actively changed the location of your application data folder (you would probably remember if you had), it will be in the default location, but hidden. While in the Finder, in the top menu bar select Go > Go to Folder… and paste into the window the following:


where Username is your user name on the computer. (You can copy the line above, paste it in, and manually edit the user name.) Click Go and post a screen shot of contents of the folder named Manager. Be sure you adjust the column widths if necessary so full file names are displayed. The next step will depend on what we see.

initially it did open, but I closed it and it has not opened since.

perhaps this was not a s clear as it possibly should have been.

After the hard drive was repaired, some previous information from the hard drive was restored to the computer, but no programs were on it, other than those which are installed as part of the operating system.
I then downloaded Manager and started it to confirm it would work.
it started and came to the create business page.
in this process it did not bring up the normal “drap application to application folder” dialogue box.
as I was unsure how to restore a business, and had to go and do some other business, I shut it down.

thinking that it should be in the application folder, I dragged the .dmg file to the application folder to the application folder and restarted it but the result was the shown dialogue box, the subject of my first email, instead of the program opening at all. all subsequent attempts after deleting, reinstalling, etc have resulted in the same behaviour.

I have followed your advice and found the folder as requested, containing this:

wow! thanks. this may actually work.

I have then followed your previous advise:

  • Dragged manager from the application folder to the bin

  • Dragged the Manager Folder in the Shared Folder to the Desktop

  • Downloaded Manager, and Dragged the application to the Application Folder

  • Dragged the Manager Folder From the Desktop back to the Shared Folder

  • Started the Program

  • Dragged manager from the Application Folder to the bin

  • Dragged all copies of the manager DMG from the download folder, and the desktop to the bin

  • Emptied the Bin

  • Downloaded Manager, and Dragged the application to the Application Folder

  • Started Manager, resulting in the same SQLite Exception Error

Dragged manager from the Application Folder to the bin

  • Dragged all copies of the manager DMG from the download folder, plus a file called Manager Alias, and a folder Called manager, containing a Buch of files, (sorry should have screen shotted this) and the desktop to the bin

  • Emptied the Bin

  • Downloaded Manager, and Dragged the application to the Application Folder

  • Started Manager, arriving at the Create Business page

I have then been able to drag a manager file for the business from the back up (after reconnecting this) to the Manager Folder in the Shared Folder, resulting in the business appearing, as it did in 2018 (all other backups contained zero bytes, and are obviously corrupted)

Thank you again

I then built up the courage to close the application (via the Command and W), and open it up again, and it still works.

Problem apparently resolved with the additional garbage in the downloads folder

I am glad things seem to be working. However, you cannot have done exactly what you described, or they would not be working. Specifically, you mentioned—a couple times—dragging the disk image (the .dmg file you downloaded) to the Applications folder. That is not what the installation Guide says to do. It tells you to first open that disk image to mount it, then drag the application icon from the mounted disk image to the Applications folder. I thought you might be doing this. But you insisted several times you were following the Guide “prescriptively.” To be clear, you cannot open the application by opening the disk image. And the disk image itself should not be placed in the Applications folder.

Also, when you thought you closed the application (with Command + W), you did not. You only closed the window. Manager itself remained open and active. If you want to close the application, use Command + Q.

Yes it is all working.

The dragging of the disk image to the applications folder occurred once, and mentioned a couple of times in clarifying the actions thought to have caused the problem. Since then, all installation attempts were done according to the procedure of opening the disk image and dragging the icon from the disk image to the applications folder. In these instances, the disk image remained (until deleted to try again) in the downloads folder.

The problem, as I determine, is that there was a folder in the downloads folder called manager, containing a vast array of files all starting with “0” (I am regretting not taking a screen shot of this, but not wanting to replicate the fault to do it again) I believe this was created when the program was initially run from the downloads folder. As there wasn’t (and in the last successful attempt, still wasn’t) a dialogue box, requesting that it be dragged to the application folder, this did not occur to me. The initial program activation (creating the Application data folder) was in the downloads folder, not in the user folder. I appreciate that doesn’t make sense, but the only rational explanation as to why it was here, and why the expected file structure did not exist within it such that it could not be found by the previous finder searches. Until this folder was deleted, it continued to bring up the same SQLite exception, and it did not work. Deleting this allowed it to function normally.

The other possibility is that another file, deleted from the same location, at the same time, called Manager.Alias is the responsible file for this unexpected behaviour.

Even though it has worked, I think it is important to understand why, so others such as @Alan_Dolan, who have encountered the same fault, have some guidance as to how to resolve this themselves.

Every time you open a .manager file, an index file will be created in the folder where the .manager file exists, unless one is already there. So all your blind experimentation, trying to repeatedly open improperly installed copies of the program, created unwanted index files.

An alias is just a shortcut, pointing the Finder towards the actual location of an application. But, depending on where the .manager file it pointed to was at the time, it would cause the creation of an index file.

The lessons from your experience are twofold:

  • Keep regular backups, because it is never a matter of whether your storage drive will crash, but when. By the way, the same advice applies to whatever drive you use for Time Machine.
  • Follow the Guides. That is why they are there.