"This business database is not valid"

Hi, I have been trying to find this exact error here in the treads, but I cant find it so I post a new ticket. This has to do with updating to Catalina on Mac, but the error message I get is quite strange.
I copied the old files in the user/.local/share/manager folder (that is the data right?) But now when I open the updated Manager program and want to open a Business I get this error message:

This business database is not valid
Manager data is stored in SQLite database. However it appears the file you are attempting to open is not a SQLite database.

Quite strange
Can you please help?

Would you be able to send me the database you are trying to open to lubos@manager.io ?

Yes I will, thank you for the quick reply

Just sent you an email with the Manager folder in zip

@olimar, you should not have had to copy (or do anything else) with any old files when you updated to Catalina. While it is always a good idea to make backups of businesses before any type of update, Manager uses the same files in the same location under older and newer versions of macOS. Why did you copy them? What did you do with them? Did you reinstall them in some manner? If so, how?

I have had this issue as well. Is there a way to recover the old data?

@cookie, “I have had this issue as well” does not provide sufficient information to offer help. If you have read this entire thread, you know that that other person’s issue has not been determined. So it is impossible to say that you have the same issue.

Describe your operating system, Manager edition (cloud, server, or desktop) and version number. Post a screen shot of the error message. Tell us what you did that triggers the problem. Have you updated Manager or your operating system software? Have you changed your application data folder? Are you dealing with your primary data file or a backup?

Apologies, I am new to this.

I updated my OS to Mac Catalina, which no longer supported the Manager desktop version I had on my computer. I updated Manager as per the instructions on the website. When I tried to open my business, it came up with the same error message as the bloke above. It also changed my business name. See image.

@cookie, your screen shot demonstrates that Manager v20.10.52 installed successfully and is running on your machine. That is good. So let’s try to get your data file to open. For background, please read this Guide: https://www.manager.io/guides/8394.

Following instructions in that Guide, navigate to your application data folder and post a screen shot of its contents. When I see what is there, I’ll tell you the next step. Meanwhile, breathe easily. The chance that your data is lost is vanishingly small. And by the way, do you have a recent backup of your business? That may be useful in what comes next.

Hi Tut, find screenshoot of the folder location below.

Regarding backup of the business, I am not certain when the last time I did this. I use this software as this is a side business that supplements my full time employment, therefore I do not access it all that often. Maybe 6x per year.

Thank you for your help in advance.

  1. Drag the first file, last modified in 2015, out of this folder to a safe place. Your desktop is satisfactory for now.

  2. Rename the file with the hexadecimal mashup to your business name as you want it to appear in Manager’s list of businesses when you launch the program, such as Cookie's Company.manager.

  3. Launch Manager and take a screen shot of the Businesses page. Post it here.

  4. Try to open the business. Tell me what happens. If you’re lucky, the problem will be fixed.

  5. If the program throws the same error message saying the database is not valid, close the program. Navigate back to your application data folder. Double-click directly on the file you just renamed Cookie's Company.manager (or whatever you named it). Tell me what happens.

Hi Tut,

I’ve done what you have instructed above. Unfortunately no deal.

Step 3, see image below.

Step 4, came up with the same message as last time. See image below.

Step 5, see image below. When I tried to open by “Choose Application”, Manager2 was greyed out and not selectable.

Okay. Those were the easy steps. This will require intervention by @lubos. I will invite him into our discussion. He will probably ask you to email him the Cook E file.

Meanwhile, you can delete the file you dragged out of the folder. It was an obsolete index file.

Thanks Tut, I will await Lubos to contact me.

@olimar and @cookie

How did you go with this? This doesn’t sound good. I’m not in any hurry to upgrade to Catalina, and I suppose this cements it for me.

Are you able to open them in older versions of manager, say before 20.10.xx?

The error is relatively weird, I can’t see how the file itself could be corrupt. Since you’re on MacOS, if you drop to terminal and run head datafile.manager (Where “datafile” is the name of your datafile, not the word itself) you’ll be able to see at least of it is an sql database or not. It will output the first few lines of the file. It might identify if there’s been any encoding errors (if for example, the database file itself has changed from or to a different ASCII or UTF-n standard)

Feel free to post the output here, there should be nothing personal in the first lines, but do remove any personally identifiable text if there is any.

@tut, are you on Catalina already? It would be interesting to note what sort of Catalina users are affected so others could avoid this in future.

When I say what type, I’m referring to new installs, upgrades, fresh installs of manager etc. last time it was the missing .local file but now there appears to be some form of corruption. That’s reasonably serious.

@cookie, you are probably upgrading from very old version (5+ years) when Manager database wasn’t SQLite. If you can email us your database to support@manager.io we will help you out.

I’ve been on Catalina since its production version was first released. The only problems I ever experienced were:

  • The need to set system preferences to allow software by identified developers (a new feature with Catalina) and
  • When Apple tightened the software notarization process for software not distributed through the App Store. It took a short while to incorporate that new procedure into Manager’s build and distribution processes. This was temporarily overcome by bypassing Gatekeeper with the two-step process built into macOS.

There have never been any issues with database conversions or formats. But I’ve never been more than a couple weeks out of date, either.

That’s probably it according to what lubos posted above. I got the feeling that his version wasn’t that far out of date, but I’m guessing now that it was.

Thanks Lubos, I have send through an email.

This is quite possible as I rarely need to do much for my business. I think I downloaded Manager around 5 years ago and I am hopeless with IT related things.

Thanks in advance.

I have the same exact problem, and I don’t have time to write it in details, can some one please help me fix it