SMTP settings not working

My new email settings are not working.

My email is set up on my web server via Bluehost.

Mac OS 10.14.5
19.7.40

I have successfully updated Manager, and re-entered my email credentials twice and updated.
When I try to send a test email. it spins for a while and then eventually just comes back to the settings page with no error or success msg.

Did you read the Guides on email? And did you Update the settings before trying the test?

Yes and yes.

Have you contacted your email provider to obtain help?

I am my email provider. It is on my web server with Bluehost. I have their settings, and they are the same for non-ssl.

Post a screen shot of your email settings page. You said you had read the Guides about emails. The troubleshooting Guide tells you what information to provide if you have a problem. You have not yet given that information.

Sorry, I forgot to go back and do that. Got sidetracked. It is attached,

Does your email server support port 587
https://my.bluehost.com/hosting/help/email-application-setup

I jut found this on Bluehost. Does it help at all? It is a little different from what it said in the first place I was looking.

This is what I had originally seen at Bluehost, so I was thinking yes, it supports port 587.

Screen Shot 2019-08-01 at 11.51.43 PM.png

I just tried changing the port, and 25 was the only other option listed so I used that. After updating the settings, the test email went out correctly. So I think it is solved unless you know some reason that won’t work.

Did you send an email to a different address? As long as that works, you are good.

Yes I did. It seems to be working.

I tried all the suggestions, on my gmail account, set up password for Manager etc. managed to send a test message, but then could only send to gmail addresses. Went back to my .nf account, set up again, and now all working for me, goes to any email address I select.