Server Edition Error (ManagerServer.exe giving Error)

Please Help!
Server Edition

Please furnish more information. Your subject says “System doesn’t start.” Do you mean your server won’t start, the program won’t launch on the server, or you cannot log in to the server? What exactly triggered the error message? It also looks like you are dealing with the 64-bit version of Manager. Is your server 64 or 32 bit?

I’m trying to open the file: ManagerServer.exe
So I can start working after that, but instead of giving me this picture:

it is closing immediately after giving me that error i posted first

it is normal windows 11 , 64bit
I have edited the title

According to the installation guides that screenshot you show is the same as in the guides at Windows | Manager

You then need to open your webbrowser using In other words follow the installation and startup procedures as in the guides.

the issue has nothing to do with the installation guide, it needs a look from the developer … he will figure it out immediatly

Did you even try to open the browser and enter ? This is the way Manager Server starts and NOT with opening ManagerServer.exe.

Your screenshot shows that the Manager server is listening on port 8080, hence the need to type the complete URL which includes :8080 which stands for the port.

There is nothing for @Lubos to sort out, you just need to use the server edition as prescribed. I think that you may have used a Desktop version before which opens through the .exe file. The server edition requires starting of Manager Server which you did correctly as per screenshot and then open your browser and enter the Manager Server URL as provided.

I did all of this … I tried to replace file by file too from a fresh copy … 6 hours trying all possible solutions

You got exactly the same screenshot as in the guides Windows | Manager under launching Manager Server by double-clicking on ManagerServer or ManagerServer.exe

So you successfully launched the server, you would not see anything else as the Manager program can only be accessed when you open your web-browser (Chrome / Firefox / Edge, etc) and navigate to You will then get the login screen.

This is the way it works.

this is what i’m getting

Why are you still trying to launch Manager server?

Manager.exe is the launcher not the accounting software.

Just open your web browser and login to this page as @eko just described three times:

Edit: the launcher is the background service which can only be launched once. So when you try to launch another instance, it should raise an error and that’s normal.

Sounds like you should try the Cloud verison

Correct. So clear all the caches and shut down your system, wait for 10 seconds and then reboot. You can then launch ManagerServer.exe by double clicking it once and wait until it shows the black terminal screen with “HTTP server listening on port 8080.” This means Manager Server is active and waiting for the application to be launched using your webbrowser. So you need to open a browser and copy and past the following URL in your browser You will then see the Manager Login Screen. Follow again the guide on how to login (username and password first time).

@Yaser I’m not able to reproduce the issue. Works fine for me. But based on your stack trace, it is crashing when loading third-party library.

Where did you obtained the “working” screenshot? On another machine?

1 Like

But now i managed to fix IT and the last data which created after the last backup have been restored, so magically it is safe now and no data loss at all.

For the benefit of others who come across a similar issue, what did you actually do to circumvent the error condition?

I have an auto backup program and I schedule it to backup the system folder every 15 minutes
then I add the backup folder + the main system folder to Google drive
and I kept checking the versions of changes on Google drive until I reached to the last working backup before the crash, so I thought it is ok, but when I ran it, it gave me blank data like a fresh installation, (All of this are on another computer, not the production machine), so I went back with the last working backup of the system folder, then I downloaded a fresh server edition again from Manager io website, then I copied the extracted files to the main system folder on my computer
And FINALLY, it is working after tons of tries in different directions
I know it might be messy, but forgive me for not sorting it in an organized way because all my focus was to fix
Thank you

So it is clear that there is no problem with the ManagerServer installation as already concluded. You never mentioned that your problem was empty businesses as you indicated that Manager would not start.

In future you are advised to do 2 things:

  1. Regularly backup each business using the backup button for each and safe in at least 2 places. As you discovered your data is more important than the application itself.

  2. If for whatever reason you do not see any businesses after an update / upgrade you need to re-import each business from back up by clicking in the homescreen Add Business → Import Business.

1 Like

Agree with you 100%, But we still need the auto-backup feature to exist with editable time schedule
Thank you!

That’s a sensible back up and recovery system.
I also use an automated backup together with intermittent manual backups within Manager.

1 Like

I just found an easy simple solution now, Usually, I’m using Dataload program for all my work
So I created a file now to create a backup every 15 minutes on another computer and it is running perfectly in a hilarious way, I will run it for a couple of days and demonstrate it here if Admin allows me
the only condition is to keep a separate PC or A Raspberry PI only for it.