Server version installation & product key

I am having a lot of trouble installing the server version of Manager. I downloaded from the site according to instructions: Unzipped and copied the folder into the root of our Win Server 2016 machine (Administrator account). Double clicking on ManagerServer.exe gets no response…no error message…nothing. An error is generated in the Event Log:
Activation of app Microsoft.Windows.Apprep.ChxApp_cw5n1h2txyewy:App.AppXc99k5qnnsvxj5szemm7fp3g7y08we5vm.mca failed with error: This app can’t be activated by the Built-in Administrator. See the Microsoft-Windows-TWinUI/Operational log for additional information.
Any ideas why I am getting this error.
I should mention that Manager Server version has been installed previously. It worked for a few days, then was not able to access from workstations. So I thought downloading the latest version might help. Not so. When it was working, I couldn’t enter the product key. There was no way to do that. Very frustrating.

How do you know the entry in Event Log is relevant to Manager at all?

Anyway, try to go to command line prompt and then type ManagerServer.exe when in ManagerServer directory. This should show some output from the app.

I checked the event log before and after attempting to run ManagerServer.exe.

It turned out to be SmartScreen that was blocking the app. I turned it off, then logged in to a user account with administrator privileges (rather than the Administrator account), and the app opened.

However, I still can’t access Manager from a workstation. The app runs fine on the server, listening on port 8080, and I can load Manager on, but cannot access from a workstation browser. I can’t work out why. It did work previously, but doesn’t now. Will try disabling firewalls tomorrow and see if that helps.

A related question: is it normal to have to enter the product key every time you upgrade the software?

try this http:// ip of your server installed:8080 ---- sample:

OK, for some inexplicable reason (possibly a Windows update), and after an overnight server failure and reboot, everything is working again. I can login from workstations using http://LocalIP:8080.
However, user accounts were not imported (as they were by the previous Server version) when I imported companies I had created in the Desktop version. I only have the Administrator account (with no password). Does this mean I need to recreate all of them?
By the way, I like how this update allows the user to import multiple companies so the user can select whichever one they want after login. The previous version I was using logged in to only one company. Now I have 2 companies listed, one for live use, and the other for practice. Very useful for new staff who are getting used to the software.

You have to recreate them, before you upgrade, the user database is in each companies file, after upgrade, the database of users are place in specific 0000000000.manager instead each company file as lubos reroll to the original design. Which means you can’t create users in desktop version anymore.

OK, I’ve recreated them. I really like the way the new Server version does logins (or maybe its old because this version is a rollback?). Now every user, after logging in, sees all the companies they have permission for, which is much better than only having one company per port.

I don’t like the data being stuck in a fixed folder that cannot be configured though. If would be much better for Administrators to be able to define the data folder. Easier for backup and safer in case the Windows partition is corrupted. And it would be much easier if the company file names could be easily identifiable rather than “RandomSetOfLetters.manager”. I haven’t tried restoring from backup yet, but imagine that it can’t be very easy identifying which file you want to restore.

You can configure your path anywhere you want on server with -path parameter

Try running:

ManagerServer.exe -port 80 -path “C:\any\path\you\want”

If you will have to restore these files from backup you are probably in situation when you will restore them all.

For moving files between servers/desktop applications: there is brilliant functionality within application itself to backup/restore and you can give any name for your file.

p.s. Make sure you do backups of application and data files regulary and before each upgrade to some safe location.

Backup files have proper names with a time/date stamp, not “RandomSetOfLetters.manager”.

Also, when you have a business open the relating “RandomSetOfLetters.manager” file is displayed.

Thanks @Brucanna. I’m actually talking about backing up the entire data folder. To my knowledge, backup using the builtin routine is a manual process. I have configured an automated backup of the entire data folder every night to be sure that I am protected. So the restore process I was referring to is actually restoring from the backed up data folder (either the entire folder or selecting only one company file to restore). This restore process could be very tricky because file names are composed of random letters, not identifiable names.[quote=“Brucanna, post:9, topic:9919”]
Also, when you have a business open the relating “RandomSetOfLetters.manager” file is displayed.
Where is this displayed? I can’t see it.

Look at the bottom right of any page. It is in very small gray letters. Here I have highlighted the letters by dragging the cursor over them.


The Manager Add Business - Import Business allows you to restore a business from the live data folder (your backed up data folder) or from the backup data folder. In another words you don’t have to have used the Manager Backup feature to do a restore.

This has only occurred in later versions, can’t locate from what version number.
It would on the opening screen after opening a business in very light grey at the bottom I suspect.

Alternatively, on a new day do one transaction in one business and close, the data file with that days date is associated with that business.