DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Manager won't start on Windows


#1

Today I downloaded and installed Manager Desktop Edition on Windows 8.1 64-bit. No errors are reported. When I start the app nothing happens. In Windows Task Manager I watched that the process ManagerDesktop.exe appears for a second and disappears. I tried to launch ManagerServer.exe as an administrator before ManagerDesktop.exe but it gave this error:

I de-installed and re-installed Manager in a different folder. It’s all the same.

Any idea what is wrong and how to make it work?


Program will not run
#2

This is the first time I see something like this but it might be related to a different problem reported by Microsoft

https://support.microsoft.com/en-us/kb/2915689

The solution is to upgrade to .NET Framework 4.5.2, see https://support.microsoft.com/en-us/kb/2901954

Try that first to see if it fixes the problem.


#3

Hi, Lubos,

Thank you for trying to help me. I guess that it’s some local problem but I don’t have a clue how to solve it.

I think that I have installed v.4.5.51650

Do you suggest to install also NET Framework 4.5.2? Isn’t v.4.5.5 includes the things from v.4.5.2?


#4

v.4.5.51650 is actually v4.5.2 so you seem to have it installed.

I think the problem is related to https://support.microsoft.com/en-us/kb/2568167

And the advice given is:

  • Remove any installed non-IFS Winsock LSPs

To determine whether a non-IFS BSP or LSP is installed, use the “netsh WinSock Show Catalog” command, and examine every Winsock Catalog Provider Entry item that is returned. If the Service Flags value has the 0x20000 bit set, the provider uses IFS handles and will work correctly. If the 0x20000 bit is clear (not set), it is a non-IFS BSP or LSP.

You probably want to run netsh winsock show catalog > lsp.txt then open lsp.txt as the command will probably output too many entries into console. See if any entry has Service Flags without any value. That could be a problem.


#5

Hi, Lubos,

I sent you my lsp.txt to support@manager.io. Can you help me identify the culprit? I don’t understand these Service Flags values


#6

There are two suspicious programs on your system which could be causing this:

  • Astrill VPN
  • WMware

Try to uninstall Astrill VPN first. Then WMWare and let’s see if it fixes the issue (you can always install those programs back)


#7

I seem to have a similar problem when trying to install the latest version of “manager”.
The install box shows up and stays there…like forever, without actually doing anything.
I am also installing on desktop, running Windows 8.1, 64bit
When I cancel after some time (about 10 - 15 minutes) it wont go away till I cancel it in task manager.


#8

Hi, Lubos,

I uninstalled Astrill VPN (https://www.astrill.com/download.php) and then installed Manager. The result is that Manager installed and runs normally. When I verified that Manager runs properly, I installed again Astrill VPN and it turned out that after that Manager won’t start again. I uninstalled Astrill VPN and Manager started normally. Obviously, the conflict is with Astrill VPN. Is there a way to make them compatible? Something in Astrill VPN prevents Manager to run. I can write to Astrill’s support but I don’t know what to tell them. What does Astrill VPN block? Any pointers?

I need Astrill VPN from time to time to use Astrill VPN services. It’s too cumbersome to install/uninstall their VPN client application and restart Windows.


#9

I would imagine that they are using the same port number? Can you change the default port number for astrill?


#10

Desktop edition of Manager will specifically look for available port number so that’s never an issue. The problem is on more fundamental level.

My understanding is that Astrill is using no longer supported Windows API calls which interfere with incoming and outgoing network traffic. This is what Microsoft article suggests. There is nothing for me to do. Astrill will need to recognize this problem themselves and fix it. Their software is breaking many other programs, not just Manager.


#11

How can i get help … in the same situation . . .manager desktop will not start (rookie)


#12

If you have the same problem, the answer is the same. But I doubt you do. So you need to provide more information. What operating system and version? What have you done? Did you get any error messages?


#13

Am using windows 10. Just one morning it did not open . . . tried uninstalling and installing again but it will not start … i do not get error messages . . . nothing happens . . . . .


#14

So you were previously using Manager successfully on the same machine? If so, and “one morning it did not open,” then something had to change on your computer: an update, a newly installed program, something. What did you do at that time?

Also, how long ago was your previously running version installed? Recognize that Manager advances quickly, sometimes with several new versions in a day. So even if you installed the older version fairly recently, you now have a new version.


#15

Try to install server edition. It could reveal the error.


#16

I have installed but it will also not work ? ?


#17

How did you determine it doesn’t work? You either got an error or it will work.


#18

I followed the process under . .https://www.manager.io/server/installation/windows
It does not load on browser . .


#19

You can post screenshot of the terminal window when you launch the server to see what it says inside.


#20

The terminal windows does not last 5 seconds . . . let me see if i can post a small video