Server Edition and Client PC

We are working on a server edition latest version (key already purchased), however couldn’t get the access thru the client PC using Windows 7, the firewall also given access to port 8080. The server is based on Seagate Tech.

Do you mean you’ve opened up the firewall on the client PC?

You need to open up the firewall to the server pc.

I’m not sure what your server is on, but see if you’ve missed anything in one of these guides:

windows: Windows
ubuntu: Ubuntu
mac osx: Mac

If you’ve followed that, then try logging into manager on the server computer itself and see if you can access the server in a local browser (this will ensure your server is working locally, and will likely point to a firewall issue).

If you’re still having problems after that, be a bit more specific about your network:

  1. What is the server installed on?
  2. Is the windows PC on the same internal network and same subnet?
  3. Are you trying to access this via the internet and/or are there any other firewalls you haven’t considered?
1 Like

4TB Seagate BlackArmor NAS 220 Network Attached Storage Drive ST340005LSA10G-RK (2 x 2 TB) 4 TB
can you guid me how to use this device to install manager on it? and other pcs on this network can acces the manager.

Im using this drive and want to use this as a host for the pc’s are on same network and on same subnet.firewalls are not the issue i disabled them to get acces.

please, read the guides posted above. That is a very good place to start. Then when you have tried it and you’re hitting stumbling blocks, come back, (start a new question), and tell us your problem and let’s see if we can work thru it together.

(Having said that, it might be about time I give this server edition a try myself :slight_smile: )

I find this thread interesting
I believe it probable that your Seagate NAS220 would be running Seagate’s implementation of an operating system known as NAS-OS, which itself is I believe, based on Debian.
Your original post would seem to indicate that you feel that you have already installed Manager onto the device, and I can only therefore assume that you have followed the instructions for installation on Ubuntu after having enabled full SSH access to the device. (I would be interested to know how you installed Manager to the device).
Meanwhile, perhaps you need to establish that Manager is actually running on the device before trying to connect to the browser-ui.
In turn, you may also want to investigate whether another process/application/service is already broadcasting on port 8080 or not, as that may conflict with Manager’s default port.
Additionally, as @d3mad has pointed-out, you may need to modify the NAS firewall settings

@xero50 these are two different people. The OP is @danowagroup. That’s the only reason I inserted the start a new question since he was piggy backing on someone elses problem

Dear All

The Seagate is a web drive which couldn’t allow to install Manager Server Ed. since it was urgent issue, we had to use a desktop and used it as temp. server, however had noticed that it allow only to run thru other PC if the firewall was disabled on pvt. even though exception was added for port 8080, this is a compromise to the security, which we never intended, yes the above post by Hassan is from same firm as our IT guy.

Ok, so you guys are together. fair enough.

The desktop version isn’t a server version at all. It is an application that runs from whatever system you run it from.

You probably could run the application itself from the webdrive, but I think you’re talking more about the database now. It sounds like you’re trying to use the desktop version as a server version, and that’s just not going to happen, no matter what ports you open up, or firewalls you disable. (it sounds like disabling your firewall has simply allowed access to file sharing which could be achieved by opening the appropriate port(s), not a web port).

At best you could share the database file between desktop versions, but I have no idea of the repercussions of that (nor have I tried) if you did that at the same time. I would guess the file would be locked to a single running instance or you risk corrupting the data.

I’ll leave that for someone else to comment on.

@d3mad thanks for comments, however we using licensed version of server edition also mentioned above.

I think it’s high time you buy and run it as well.

@danowagroup no probs, there was confusion all round mainly because I didn’t realise you guys were from the same office. And I had forgotten the original post said it was the licensed version. My bad. I do plan to try the server version once we open the doors. Cheers.