Printing and PDF

Good day
I am not sure if this is a bug or something I have not set up.
I have just installed the latest version and created a new business. I now notice that I cant print anything, Manager seems to hang when trying to load printers. I cant even get to see any printers. Also when I view an invoice there is no longer an potion to save it as a pdf. Any help would be appreciated.

Thank you
Shaun Fisher

When it comes to the PDF button, It’s more of the latter. The internal PDF generator has been discontinued and now sits in the Settings > Legacy Features, where you activated. But you should know that this feature is no longer supported.

As far as the print hanging, this seems to be an issue with your computer, most likely your printer drivers, print spooler or printer connection. But it’s too early to completely dismiss a bug so, please do the following:

  • Share your Edition of Manager and your Version number

  • Share screenshots of the error

  • Clear your print spooler and restart your computer as well as your printer, see if that solves anything.

ok it looks like manager is looking for a printer that is not installed on my pc. I deleted that printer as it is no longer in use. how do I reset manager to look for a new printer, My print spool is empty

What alternative is there for PDF

The Print function also allows to print to PDF in the dialogue.

Yeah if I can open the print dialog, see my message above

The problem as you indicated is with your system and printer driver. This in essence is not a Manager issue. Maybe if you provided much more details such as what operating system (Windows, macOS, Linux?) and version (Windows 11, Monterey, Ubuntu 20.04?), the printers installed and if these work with other applications than Manager including print to PDF. The browser used and if you can print for example a BBC news page to paper and to PDF. I would recommend also to try another browser to review if problem persist.

I am using windows 10 and can print from all the browsers I have installed and any other application. as far as pdf goes I can now save to pdf after I set the " Settings > Legacy Features" setting so that is no longer an issue. Its just the printing to printer now. I have even uninstalled and reinstalled manager to no avail. The older version of manager worked fine with no problems. While I am venting… Email… the new email attachment mmmmm I dont like… i can read email on one pc but not on another. Far prefer the old attached method.

As shown by the screenshot you have posted, Manager doesn’t connect with your printer directly; it’s the browser that takes over after you click the Print button.

So resetting Manager wouldn’t help at all in this case.

Also you said that you have deleted a printer but its ghost still appears in your browser. A quick fix is to restart your computer and that should get rid of the ghost.

Done that still no joy

I have even tried changing my default browser details and nothing…
BTW I use google chrome and Microsoft Edge. Funny thing is, this stared happening after I upgraded manager. Is there any way I can revert to an older version while using the same database

Check this support ticket at Microsoft:

Only with a backup business file you haven’t opened in newer versions. You can find older versions of Manager on github:

Ealfardan, I have done what was suggested in the link you sent me but still no go. manager is still looking for the old deleted printer. I will go see if there isn’t an entry in the registry… will let you know

Looking at your screenshot it seems to be related to This document requires ‘TrustedScriptURL’ assignment – JavaScript

Yes but is that not a manager function? I found some entries in the registry related to the obsolete printer, removed them but still no joy

You might have tried this already … without opening manager at all can you print successfully to your printer … print say an email or a webpage article? If you can print the above OK to your default printer (do not let Windows control the default) then open manager and test printing again does it work?

No it isn’t. As @Ealfardan explained:

We try to help you resolve the issue even though it is related to your system.

I have tried the latest version of manager on two different computers and have similar issues. printing problem on both and accessing an emailed invoice. I have reverted to an older version of manager and have no problems. yes I realize that PDF is obsolete but it works!!! Such a pity because I really like Manager