Printing A4 Forms

I’m currently running V 19.6.10 and over the last few days, I’ve found that my Sales and Purchase Invoices are not fitting on an A4 sheet.

If I save the invoice as a PDF it seems to be OK

Paper size is picked up from your Email Settings in the Settings tab.

Thanks @Tut, I do have the email settings set at A4 but am still having the problem.
It looks to me as though the LH margin is much too wide causing the overlap.

Are you using a custom theme?

No @Tut, just the standard theme.

I’ve also just updated to the latest version of Manager and it’s still just the same.

I also totally uninstalled and and re-installed my printer but all to no avail :astonished:

Can you post a screen shot of the Edit screen for the sales invoice you are showing?

Sorry mate, I’ve just realised that it is actually a custom (or “modified”) form that I’m using as I do have the extra column for “Serial Number”.

This does not look like you are using a custom theme. It looks like you have created a line item custom field labeled “Serial No:”. Any of the built-in themes should handle this. Can you try a couple of the other themes and see if the problem persists?

Sure @Tut , I’ll give it a go.

Strangely, this problem has only happened over the last few days.

Is there an “easy” way to change the margin sizing on what I’m using currently ?

That depends on what you mean by “easy.” There is no easier way than creating a custom theme. But this should not be necessary.

I am more concerned with why you have this problem. Can you explain in more detail exactly what your first screen shot is showing? I can create a sales invoice with a line item custom field for serial number. I can also add an inventory item custom field for pick location and a very long entry in the description field. Both the direct PDF button and the Print button result in a document in which the column widths are adjusted to fit everything within the limits of an A4 page:


My point is that you should not be facing this problem at all. And you definitely should not have to create a custom theme to solve it.

Thanks again for your help @Tut.

The original screenshot shows how my invoices are printing if I use the settings that I’ve always used and as you can see, the RHS of the invoice is “chopped off” with the “Amount” column missing and a large margin on the LHS.

As I have mentioned, if I select “PDF” instead of “PRINT” a PDF is created that looks totally correct and I’m able to print the PDF without a problem.

When this issue first reared it’s ugly head, as mentioned, I totally removed (uninstalled) the printer from the computer and reinstalled it from scratch but alas, this exercise didn’t help.

To make matters even more frustrating, this morning I tried creating and printing my GST Report for June and both the Print Preview and PDF came up with what you can see in the new screenshot.

With this report, it looks to me as though it is trying to print on a smaller sheet (possibly letter size ?) as the margins all look OK but the page looks to be shorter than “normal”.

The next troubleshooting step I was going to try was to install Manager on another PC using a backup of my current data to see what happens and then, possibly totally remove all traces of Manager from my “main” PC reinstalling Manager and using a backup file to get things running again.

In doing this however, I’m wondering if there’s any incorrect print settings (or other bugs) saved in the Backup File that may just carry over to the newly installed programme ?

Thanks again for your interest and support, it is really very very much appreciated. :grinning:!




Based on your last answer, Manager is correctly doing what it is supposed to. The error occurs when using the Print button, when your operating system takes over. I think you have printer setting issues.

Moving a backup to another installation will transfer all settings. Unless you have a different printer, I think you’d be wasting time.

Hi again @Tut.

Yesterday, I went out and purchased myself a new “cheapy” printer to see if I could solve the problem that way but alas, no such luck.
I have managed to sort out the issue in printing the GST Reconciliation Report by importing and installing

Importing and installing what? And what are you referring to by “GST Reconciliation Report?” There is no report or localization in Manager by that name.

I installed the file referred to in this thread:

Yes I Had the same problem and was advised by Tut to reinstall, localisations for New Zealand, Fixed the problem for me