DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Possible Bug with Recurring Invoices


#1

I am preparing my files for a restart for next year, we have changed quite a bit and want a clean start. I have many recurring invoices and to test them to make sure everything is correct I have changed the date on my system to 1/2/2019 (invoices are set to trigger on 1/1/2019). It adds a blank one at the very beginning. There is nothing blank in the Settings > Recurring Sales Invoices portion of the system.

Here it shows me 26 recurring invoices to be enterred:
24%20PM

When I click the button to create all recurring invoices, I get this as an option. I cannot uncheck the box:

Once all invoices are created, the first one in the batch shows Customer as suspense and if you look at the invoice just below it, you will see there were 27 invoices entered (26 legitimate + 1 empty)

Running manager server 18.9.48 downloaded and installed as a first attempt to fix the problem.


#2

You seem to have a recurring sales invoice defined for an incorrectly entered customer (no name). Can you post a screen shot of the Recurring Sales Invoices page under Settings?

As for the counter, the +26 number indicates the number of customers for whom there are pending invoices, not the number of pending invoices. Because you have only 26 customers specified, it showed 26. But when you created all pending invoices, 27 were created.

Once you have eliminated the unnamed customer, a counter of +26 would generate 26 invoices, unless you are late. For example, if all your recurring invoices are monthly and you wait two months, you might see +26 in the counter but get 52 invoices.


#3

I counted the recurring invoices in the list, there are 26 and none of them are blank. I would prefer not to post a list showing customer’s names, but i can confirm 100% that all 26 of them have names. The system entered 27 invoices, all 26 correctly and an extra one.

I disagree with this. I have two invoices for 1 customer and 3 invoices for another (different locations). The total number of lines in Settings > Recurring Sales Invoices matches the indicator (26)


#4

You are correct about the way Manager counts pending invoices. I was just using a simpler way of explaining it. I apologize for not being totally rigorous. The complete explanation is given in the Guide as:

When one or more recurring invoices are due (or past due) to be issued, two notifications are provided. The first is a yellow counter window in the left navigation pane showing the number of recurring invoices for which invoices are pending (not the number of pending invoices, which could be higher if you have not kept up by creating invoices that are due).

I accept your word about this. But Manager somehow thinks you have an undefined one. I can replicate the exact behavior you described by defining a recurring sales invoice while leaving the customer blank. So the question is why Manager thinks there is a recurring sales invoice you don’t have on your list. Possibilities include:

  • You defined a recurring sales invoice, then deleted the customer.
  • You defined a recurring sales invoice, then made its customer inactive.
  • You changed the name of a customer.

I have not modeled all these possibilities, so I don’t know what could happen. But I believe the solution will lie in actions you have taken with respect to a customer in the past. I would begin by checking that the new list has all the invoices on it you expect.


#5

I checked all three scenarios. The only one that has happened on this file so far was I did change the name. I deleted the invoice from recurring and tried again with no luck. Here is a screenshot of my Settings > Recurring Sales Invoices screen where you can see there are 26 line items.

Also here is the screen where you would click to enter all of these recurring invoices. Every one from the Settings screen is there and the blank one.

For what it’s worth, I did advance and try to enter a second round of invoices thinking that maybe it would be posting a blank invoice because there are zero invoices in the system up to this point. That did not work, it still posted a blank one the second time around. Also it is the first invoice in the list both times.


#6

Since you are still experimenting with a new setup, not real accounting data, what happens if you use the Batch Delete function under Settings > Recurring Sales Invoices? First, what shows when you first click Batch Delete? Second, if you click it and then enter some recurring invoices, does this phantom invoice show up again?


#7

Thanks again for your suggestions. I duplicated the company by backing it up and importing it. I used batch delete to delete all but 1 invoice from my recurring invoices section (I did this in waves of 5-7 invoices to see if one of them cured the problem) with no luck. Here is my batch entry screen with only one single invoice:


#8

I also deleted the last invoice from recurring and added a new one and the phantom invoice reappeared.

28%20AM


#9

@lubos any help here?


#10

Can anyone else produce this or help with this? We are at a standstill preparing for the new year until I can figure out where these phantom recurring invoices are coming from. Any help would be greatly appreciated.


#11

I have experimented with this some more. In addition to the earlier method of duplicating a blank invoice I mentioned (leaving the customer blank when defining the recurring sales invoice), I can duplicate the behavior by editing the customer directly and deleting the name. But both situations are explainable and do not produce “phantom” invoices.

I once discovered a bug with phantom entries for Fixed Assets. But that was a repeatable bug. (The entries were real and necessary. They just were not supposed to display.) This one does not seem to be repeatable based on the information you have provided.


#12

Thanks for your efforts here. I am not sure how else to explain what is going on, I have tried deleting all recurring transactions and adding a single recurring transaction with a single item. When it is entered it creates two, the one I created and the phantom one. We can’t have blank invoices and definitely do not want missing numbers in our sequences.

@lubos can I send you the backup file for investigation?


#13

Should be fixed in the latest version (18.9.85)