Not Able To Send Emails (Manager Server / Ubuntu 18.04.4 LTS)


I recently changed my hosting provider and now I can’t send emails anymore through the new provider on port 587, even though I can send emails with the same settings using Thunderbird / Microsoft Mail. Using the “Test email settings” gives the error “Message could not be sent”.

Environment: Self-Hosted (Ubuntu Server 18.04.4 LTS)
Manager Version: 20.2.33

Manager will send emails on port 25, but that is not an ideal long-term scenario.

I’ve attached some screenshots of both the Manager Email Settings Page and the Thunderbird SMTP Server Settings.

Any solutions to this problem would be welcome.

I agree, you shouldn’t use port 25 unless troubleshooting. Could the issue be with trusted root certificates?

Can you try to run:

mozroots --import --ask-remove

Then try sending email from Manager again.

Thanks for the reply Lubos.

I ran that command and still got the same error unfortunately.


Thank you for the assistance and pointing me in the right direction.

The problem has been solved and the good news is, Manager wasn’t at fault :smile:.

It was an Exim certificate issue, where Exim wasn’t able to read/access the SSL certificates. It wasn’t initially obvious as a) Other mail programs worked and b) the websites were secure with the SSL certificate.

Thanks to God, Manager, your suggestion, the error logs and a crap load of Google searching, I found the solution.

Changing the owner of the SSL certificate directory to Debian-exim and the permission to 750 did the trick.