DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

No luck with custom SMTP


#1

I’m trying out this program (14.9.18 desktop) for my new business, and so far I am very pleased and impressed!

A problem I’m having, however, is using SMTP with either gmail, or my webhost-provided account, both of which work fine with Thunderbird, using the same settings. It took me a little while to realize that the default email setting uses your own server, which is nice, though perhaps one shouldn’t be allowed to fill in a different “from” address, which was confusing.

I just would prefer that recipients could simply use “reply”, which is the main reason I’d prefer the custom SMTP setup (unless you wanted to implement an additional “reply-to:” field)

Are others having success with SMTP? It’s acting buggy with me…


Issue with email - server edition
#2

Which SMTP port are you using? Manager currently doesn’t support TLS/SSL only STARTTLS. Thunderbird supports both.

So I assume your settings don’t work in Manager because you are using port 465. Can you try port 587?


#3

Thank you for that, Lubos! I thought I had already tried that port, but just now I experimented again, and it does indeed work with my webhost-provided email account (h—monster), but now Gmail is giving a rather tantalizing error message to the effect that my machine (ip address:port) “is currently not permitted to relay through this server”.
I thought perhaps the problem was being logged into gmail on my personal account, so I exited and logged into my business gmail account (as per manager) and re-tested, but same message! Any further thoughts for gmail? Pretty sure gmail supports TLS. Thanks!


#4

Okay, I now see that I merely goofed with a typo! Sorry about, but thanks for the help! Gmail good.


#5

That information about not supporting TLS/SSL and having to use port 587 is really important for those who are trying to using gmail’s smtp.

I tried a couple times with 465 and it just could not work. Changed to 587 and it worked. All the guides on the net suggest 465 as the port to use with gmail. But I guess you’re probably planned to support TLS/SSL in the future.