Can't send email from Manager anymore

I am not sure when this started but I can’t send emails to my clients from Manager anymore. The settings are correct. Ideally the port should be 465 for SSL but this was not a problem. My SMTP server supports and non SSL port connections.
Whenever I try to send a mail or whenever I try to check the settings I get a spinning wheel and then nothing. No error messages or anything. It just not sending any message.
Version 19.7.65

Unless you post more information, all that can be said is have you read the guides about emails

The system changed some time ago

I have read the guides of course. And everything was working OK until recently. I think an update “broke” the email sending function. I just tried changing the port to 25 and it worked OK.

@Manos_Krokos, if you want help, follow the instructions at the end of this Guide: https://www.manager.io/guides/9100.

Like I have mentioned above, I have read the guides and the email was working fine with port 587.
Somehow it stopped working and I had to change it to 25 to make it work again.