Manager won't open after upgrade to the latest version

ManagerDesktop v21.2.30 doesn’t appear to run at all (stop so rapidly without a reporting an error that I can’t detect it ever running).


  • Tried in Windows 7 x64 professional
  • Uninstalling webview2 made no difference
  • Updating Webview2 to current version made no difference (X64 v88.0.705.63 evergreen but internet access blocked)
  • disabling UAC made no difference (Manager installed in c:\programs x86\manager)
  • Starting managerServer.exe in the desktop install runs normally (with usual missing setup json file error)
  • ManagerDesktop v21.2.24 run without issue with edgeview2, eto error without edgeview2

When I first installed desktop version 21.2.30 it also didn’t run at all on the first three times I clicked on it. I checked the Task Manager and couldn’t see anything that looked like Manager running. I restarted my computer and then ran the install file again to repair the installation. After that on the first attempt at opening it I got the same error described by the original poster in this thread, and on the second attempt it opened fine.

@Patch have you tried repairing the installation?

I just upgraded Desktop version 20.2.24 to 20.2.96 (from memory, because I can no longer see)
2.24 worked fine, but I cannot open 2.96
My system is Windows 10, 64bit
OS Name: Microsoft Windows 10 Pro
OS Version: 10.0.19042 N/A Build 19042

Sorry, that should be 21.2.24

@jonjus10, can you provide more details? Exactly what happened when you tried to open the program? If there were error messages, post screen shots.

Ok, so I did the upgrade and when I clicked the icon, the wait circle showed for a second, then nothing. No error message.
After reading previous posts, I decided to uninstall and start again.
This time, during the install, it prompted me to install Webview2 runtime and after that, it is now working.
So, to summarise, the update didn’t prompt me for Webview2, but the new install did?
All OK now, thanks for your follow up.