Manager won't open after upgrade to the latest version

I’ve updated the Manager to version of v20.10.89. The problem still persists.

I moved this topic to the bugs category.

We have already determined that the developer needs to fix something with Manager. You can’t fix the problem by updating Windows or .net through Windows update.

I believe that the problem is an issue with Manager and the .net Core included with Manager. Thus Manager has a bug. It is not an issue with users computer’s given that several people are experiencing the same problem.

I would guess WebView2 Runtime Library interaction with Edge on windows

Hi Tut,

To my surprise, I can open Manager as usual now although I did nothing to it.

In my experience the problem seems to be intermittent. In about one of four attempts it seems to open fine, but in the other three it gives the error. I haven’t been able to work out what makes the difference. @VACUUMDOG mentioned some apparent problems when using Edge at the same time. If you notice any patterns for when it works and when it doesn’t, let us know.

Be interesting to see what the problem is whether it’s .net or the Webview2 issue. My experience is .net tends to cause problems with various Windows programs. However Webview2 is a relatively new feature, so not sure how reliable this is. I am not sure what is taking the developer so long to fix it as it’s clearly a bug with Manager.

I don’t think this is a bug in Manager. It looks to me like a bug in some Microsoft sub-component.

Is this issue with WebView2 component? If Manager is not working, you can try uninstalling Microsoft Edge WebView2 Runtime to see if it fixes the problem. If it does, then the issue is in this component.

Also, all 3 people who have posted their screenshots have the program failing differently. So I do not have much to go by currently.

Could this be related to the problem where people could not backup manager because I presume something was locking a file? Could there be some kind of conflict between Webview2 with edge and Manager so two programs trying to use the same file simultaneously?

I will download desktop manager and see if I have the problem. I use the server version.

One thing that I have noticed is that every user that is experiencing problems started experiencing it after updating Manager - has something changed within Manager that could be related?

A lot of things. No dependency on .NET Framework anymore and bundling .NET 5 instead. Support for new WebView2 component. I think these two are the biggest ones.

But in both cases, this would be for Microsoft to fix at their end. Considering Manager is one of the first apps to be built on .NET 5 and WebView2 (less than a week from release) this means Manager users would be the first to experience any issues. Other apps might take year or more to migrate and by then, the platform would be a lot more mature.

Now, moving Manager onto .NET 5 and WebView2 was necessary to solve other issues so I couldn’t wait for this to happen sooner. I’m pretty sure this problem will go away on its own even if we are not able to figure out the reason.

I have installed Desktop manager on my computer W10 20H2, installed the Webview2 program and manager works perfectly. I even tried opening other programs such as Edge, Word etc to see if there was any kind of conflict.

I would suggest looking at event viewer to see if it gives you any clues as to what the problem is. It could be a conflict with your anti virus program or some other program that you have installed, that I don’t.

@lubos I am aware that a lot has changed over the last few months. What I meant was has anything changed in Manager updates in the week or so. This problem has only started cropping up in the last week.

Just re-read your post. If I have understood you correctly, Webview2 Manager update is around a week old?

Well the affected users can follow your suggestion and remove Webview2 to eliminate this from the equation to determine if the issue is .net or Webview2. And if they can look at event viewer this might give some clues. It is clearly not happening on all W10 computers so I suspect a specific program on their machines is causing the problem most likely the anti virus.

The changes happened last month but a lot of people tend to upgrade after receiving the newsletter which was a few days ago.

That makes sense. Looking forward to your input on Tut’s discussion on the standardisation of transaction layout as we have come up with 2 proposals for you.

I believe I used several versions of Manager that were bundled with .NET with no problems, and the problems started with the first version I downloaded that used WebView2, so to me it seems the issue is related to that somehow. (I can get specific version numbers when I am back on my work computer.)

I run Manager on two computers, but I’ve only experienced the problems on one of them. The problematic one (my work one) has much less software installed on it. The other one (my home one) has, I believe, all the software that my work one has, plus much more, including the same anti-virus. So, I would think that if there’s some sort of software conflict on my work computer I should experience it on my home computer too. (No doubt, however, there will be small differences in the operating system, drivers, etc. The two computers have very different hardware.) I am on my home computer now, but will see if I can try the suggestion of uninstalling WebView2 the next time I experience the problem on my work computer.

Try uninstalling Webview as the first option. But don’t forget to look in event viewer as well.

If you are using the same programs, anti virus on both computers, then it’s unlikely that this is the cause. Are you using the same Windows version on both computers, for example you might be using W10 home at home and W10 Pro or enterprise at work?

You could have some policies at work that could be causing the problem blocking the running of something.

I removed webview2, and just hit the red x on the install webview2 box when opening Manager.
Have not had a Manager white screen of death since.

Anything in event viewer giving you details as to why Webview2 is not working. The problem is not Webview2 itself given that myself and other people have no issues with manager and Webview2. could it be a software restriction policy on your computer, an issue with a specific driver or something?

What does event viewer say?

I’m removing this from bugs since it cannot be reproduced at our end.

What I suggest is to uninstall WebView2 component and see if Manager starts working. Seems like this will solve the issue for now.

WebView2 is the future and Manager will be prompting to install it but perhaps try again installing it in a few months. Hopefully that should be enough time for Microsoft to fix this at their end.

I have not experienced the issue again in about a week. I haven’t changed anything major on my side, except perhaps installed some Windows updates, but I can’t remember if all of those were before I last experienced the problem or after. I’m hesitant to say it has been fixed or gone away, as for me it was intermittent anyway, but Manager seems to be working normally for me. I haven’t opened Manager more times than I’ve needed to.

I have experienced this issue a few more times since my last reply to this topic, most recently today after my update to 21.2.30 desktop edition on Windows. On the second attempt at starting Manager it worked fine.