Desktop Edition Crashes on Launch

Hello all,
Just today, manager desktop decides to crash on launch.
Win 7 Pro
Uploading the first page of the detail. Can provide more, but there is a bunch.

Never gets to business selection.
Manager has been installed and operational for a while, so suspect Windows, although there have been no recent updates or changes to the OS.
Tried uninstall/reinstall to no success.
Any help appreciated.

Looks like there was an Edge update installed yesterday.

Tried uninstalling Webview runtime and reinstalling, then uninstalled both Webview and Manager allowing Manager to install the runtime version. Same version (108.0.1462.44) is always installed with no luck.
Found an older version of Webview runtime, but it is a .cab file an I don’t know how to deal with those…

So still looking for help.

@Scott.E, what version of Windows are you running?

@tut he stated:

Sorry I think @Tut meant 64-bit version of Win 7 Pro or the 32-bit version. The error screen you showed relates to the win 32-bit version so you must be sure you installed Manager for 32-bit and not 64 bit see Download | Manager and select the Alternative 32 bit download for Manager and see if that works. Make sure you uninstall the 64-bit version first.

Win 7 Pro 64 bit is installed.
Manager also is 64 bit installed.
If you read my first post, Manager had been functioning for over a week until today (although I said “a while”), so proper versions were installed. Not sure why there are references to 32 bit on the details.

I have just installed the same version of manager on a win 10 Pro 64 bit machine
This machine has a previous version of Webview runtime (107.0.1418.62) and manager runs fine.
I don’t know if the new version of runtime is defective or only defective on win 7.
Have turned off update (disabled services) to webview on the Win 10 machine until I get this figured out.

Yes, @eko, I was wondering about 32 vs. 64 bit. I should have been clearer. I’m puzzled by multiple references to 32 bit in the error message. But I am not a Windows expert.

I read your first post but for whatever reason you did something that a reference to a Manager 32-bit version. Obviously a Manager 64-bit version works on a Windows 64-bit version. That would be true for Win 7 and Win 10.

The screenshot you showed tell us that you have installed the following Win32 versions with the links to the files (file:///c:… etc) installed:

a. System.Private.Corelib
b. ManagerDesktop
c. System.Runtime
d. Eto

and probably more. So if not fixing this it will not run.

On Windows 10 64 bit I’m currently using
Webview2 is installed in C:\Program Files (x86)\Microsoft\EdgeWebView\Application
But I think this is actually the 64 bit version thought, or at least that’s how it shows in the Task manager when running. So perhaps ensuring @Scott.E ensuring he has the 64bit versions on Windows is worth checking. To do so this post may help New Update - #4 by Patch

I’m actually running older versions of both Manager and Webview2 so would not expect to see issues with recent updates (I manually update these programs at a time convenient for me, by blocking Webviewupdate, Webview2 and Edge internet access).

1 Like

Thanks for the response, @Patch. Ran through your suggested script, but with no success.

The only item idea I can’t seem to accomplish is to roll back Webview runtime to a previous version on this machine. The problem arose the day after there was an automatic update (to 108.0.1462.44).

I am also unable to open Manager and access my data, I have been trying for an hour but only displaying this:


Windows 7 32

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Users/***/AppData/Roaming/Manager/ManagerDesktop.dll

@lubos any help?

No problems here with latest Edge update on Windows 10 Manager

What exactly have you been trying to do? I would uninstall Manager and WebView from Windows’ Apps & features settings, and then download Manager and reinstall it again, which will also install WebView again.

This seems to be related to a bug with webview runtime 108.0.1462.44 when trying to access local files.

The problem seems more prominent for older versions of Windows, namely Windows 7.

This is Microsoft’s github bug report:

I have updated the program and also then uninstalled Manager and WebView2
No joy.
There seems to be a fixed version of webview2 in:

But I cant work out how to run the previous version 107.. from the later 108..

This is a nightmare, no manager all day.

For the time being you can use Manager Server, which is included in the same application folder.

Thanks @Mark ,

Im not sure what you mean. My App Data file?


I don’t have those listed in my hidden folder.

Sorry it’s a photo, I had to quickly take it before closing the computer down.

You’re in the wrong folder.