Manager will not open on Mac Sierra 10.12.2

Hi. I am all of a sudden unable to open Manager on my MacBook Pro. The icon that looks like a portable drive is on the desktop screen , but when I click on it and choose “open” it disappears from the row of apps at bottom of screen. I am very concerned! Please help :slight_smile:

I also run macOS v10.12.2. Just two hours ago I downloaded and installed the latest version of Manager, v16.12.50. I can assure you there is no problem with Manager. Nor is there any incompatibility with macOS Sierra.

You should not be “clicking” on on any downloaded Manager icon to open it. You should drag the icon to your Applications folder. Follow the instructions in this Guide to the letter:

Thanks so much for your response. I’ll try to do as you’ve suggested. Apologies for probably not providing a well-constructed description of what’s happening… I’m smart enough to know that whatever this issue may be it probably is due to my own lack of knowledge/expertise! Thanks again! Hope I can figure it all out :))

No worries, @GBA. Updates are when most bugs are first noticed. If a complete update in accordance with the instructions doesn’t remedy your problem, post again with exact details of what you did, in what order, and what you saw as a result.

Hi @Tut I have just tried (Twice) to download and open the latest 21.5.15 because my previous version 21.3.75 does not appear to be backing up anywhere. I click backup in the programme, up pops the screen. I hit backup, but unlike previously that then asks for a location to backup. It looks like it is backing up, but where I do not know becasue I cannot find it anywhere. I like to back up to 2 different locations. I am running High Sierra on my mac, and it says for 10.13 or newer, I am running 10.13.6

@norfolkislandam, your post is very confusing. You posted in a topic about macOS 10.12.2. But you say you are running v10.13.6. You begin by saying you tried twice to download Manager v21.5.15. But everything you write about pertains to backing up from v21.3.75. So I do not know what your question is.

Hi @Tut a bit confused, didn’t mention macOS 10.12.2, but I did mention I am running 10.13.6, (High Sierra) which is above the min requirement (10.13.0) for the download v21.5.15.
Anyway, I restarted my computer and it then allowed me to load and run v21.5.15, it now backs up correctly to wherever I chose