Manager not starting up after free download

Comp - macOS High Sierra version 10.13.6
Manager - version 21.1.7
Manager working fine yesterday and back-up taken
I go Safari, Google, free accounting software and it gives me relevant page
Download begins and Manager.dmg appears on desktop.
Double-click manager.app and then open
Gives me business screen. Screen Shot 2021-01-05 at 14.13.22 There are 11 businesses but most are closed as I don’t do accounts as a job anymore. Also a black message at bottom left not noted before. in bottom let hand corner


2 of these businesses are used currently - neither will start up
There is one missing altogether and the backup is in the dropbox. (This is because my daughter manages her account and sends me backups because I help her) I say this is a new business and use the dropbox last backup. I have tried several of the backups but nothing is working. Screen freezes and won’t do anything. I have to quit and it gives apple message.

This is not the correct update sequence. After you have opened the disk image, you should drag the Manager icon to your Applications folder. Perhaps you neglected to mention that you did that. Regardless, the program launched and shows the businesses in your application data folder.

The procedure for setting the application data folder path was simplified just a few days ago. This was announced in the January newsletter. See the Guide: Move desktop application data to another folder | Manager. Your screen shot shows that you have your application data folder set to the default location, so that is fine.

It is not clear why you are showing the screen shot showing a list of backup files. Where is this from?

Also, exactly what triggers the screen freeze?

No, not neglected to mention because have never done that in all the years used Manager.
Sorry I have not taken on board guide for moving to another location. You say “that is fine” so does that mean I don’t have to do anything?
The backup’s are in download file and only did to show I keep regular back-ups.
Manager opens on businesses page - if I click on either of the two current backups it freezes. (That’s LH and Wyatt Design.) If I don’t touch them but try to put the missing one on from a backup it also freezes.

Age and disability taking their toll. Now I am not sure if I am using the forum correctly. Apologies if I am not. Hoping I have managed to get my reply to you.

It means your business data files are in the default location. So you do not have to do anything unless you want to store them somewhere else.

You succeeded unless you have posted more than three posts in this thread.

As for the cause of your freeze:

Your operating system version is getting pretty old. But, if you can run High Sierra, I think you should be able to run at least Catalina (macOS 10.15). And the update should be free. You might try that.

First, though, I would try installing the application in your Applications folder according to the Guide: Install or update desktop edition on macOS | Manager. Let me know if that works.

The error message does not contain anything useful to determine what is wrong. MacOS 10.13 should be fine.

I’m currious, can you try version 21.1.6 to see if the same issue persists.

Version 21.1.6 is available from here: https://github.com/Manager-io/Manager.dmg/releases/download/21.1.6/Manager.dmg

Downloaded version 21.1.6 and everything worked. Will do outstanding work and produce a backup file for each of the 3 'businesses" I use. Thank you - have been so worried.

Will I have a problem with a higher version in the future? My daughter uses whatever the highest version is and then sends me copy backup. So I have to use same or higher version to use her backup.

On the paper, there shouldn’t be an issue with 10.13.6 but apparently there is. At least on your machine. I think you will have no choice but to upgrade to newer MacOS as per @Tut suggestion.

@patchworkfields, you should be able to download later versions of Manager (21.1.9 as I write this).

A test was performed on an older Mac running macOS 10.13.6, just like yours. Manager froze on the first launch attempt, but opened and ran successfully on subsequent attempts.

Such initial crashes or freezes after updating Manager have been experienced extremely rarely. I don’t know the reason for them. But subsequent launches have worked in those cases. If you have problems, you already know a fix that will work: reverting to v21.1.6. (Of course, you didn’t used to be able to do this, but after a recent change, you now can.)

I tried current version and businesses screen froze as before. So used your link for v21.1.6 and lost all the names as screen shot.

Do you have multiple backups of your businesses data files?

Ps I am not saying you have lost your data (assignment of names to businesses files have changed). But I do suggest you retain the ability to reverse changes made while experimenting.

Yes I have minimum of three per business - but I only access three businesses now because I no longer do accountancy work.

I have asked my daughter what her Mac uses and its Mohave… She says I can update but neither she nor I are able to go to Os big boss. In the meantime I am having health issues and my computer has gone to her for whatever upgrade possible. I only have my pad and am unwell so will hope to return to forum query next week if still got problems.
Thanks to help received so far.

I do not understand this comment. The fact that these files show on your Businesses page means you did not lose them, but that they are in your application data folder and are being interpreted by the program as business data files. They look like the old hexadecimal file names under which business data was stored before the change to plain-language names. The exception is the one that is all zeroes, which looks like an obsolete index file.

Sorry. Appreciate “lost” probably wrong word but names of businesses gone; replaced by numbers. No idea why nor how to change it back. And struggling to use forum on pad. Will come back to forum when computer comes back to me and I can be more precise. Thank you

You can use the Rename function next to the names at the top of the window after opening a business. Or you can rename them in the application data folder.

Thanks for assistance. Still have no idea why things went wrong but my daughter seems to have sorted it by upgrading my computer to BigSur and rearranging how we share the account. Everything went well this morning. We have made sure we keep a copy of the 21.1.6 version which we know works. Thanks again