Manager IO not functioning in my Computer

Manager IO not functioning in my Computer. Nothing happens when I clicks on Manager Icon. It is not opening and no any messages showing.

Try double-clicking?

Yes Sir. As I mentioned earlier, I am using this Software for the past 5 or 6 years. And using this in my computer with the same Windows 10 Home Edition. But the problem not opening started 5 days ago only. I thought it might be a problem of my Windows and that is why I re-installed Windows. But still the same problem. While double clicking on Manager Icon, mouse pointer rounds of 5 seconds and it stops. App not opening at all. Waiting for your valuable comments. I really need help.

I flagged your opening post because you keep opening and responding to topics about the same. We also asked you multiple times including by the develooer to provide more details. If you want us to help you you should not crosspost and supply the information requested,

Also look at the recent post by @Lubos on supported operating systems:

As for Windows Requires Windows 10 (64-bit) or newer and for Linux Requires Ubuntu 20.04 (64-bit) / Fedora 38 (64-bit) or newer

@sibykumar try to download server edition from https://www.manager.io/server-edition, unzip the file and launch ManagerServer.exe to see if it shows any error that way.

Dear Sir,
After several uninstall and install, I had solved my problem myself. Manager io release 24.2.28.1328 is opening in my System running Windows 10 Home Edition 10.0.19045. Any of your other new releases are not opening. Manager io Release Version 24.3.26.1364, Version 24.3.26.1370, Version 24.3.27.1373, Version 24.3.28.1376, Version 24.3.29.1378, Version 24.3.30.1380, Version 24.3.31.1383 & the latest release Version 24.4.1.1387 (https://github.com/Manager-io/Manager/releases/tag/24.4.1.1387) which is the latest added on 1st April 2024. The above-mentioned Versions are not working with my System. Now need suggestion and solution, how I can keep updated my Manager IO with the latest releases.

@sibykumar what about the just released version 24.4.3.1393 ? Can you test?

No Sir. I tried. Just released version 24.4.3.1393 is also not working.

Release 24.2.28.1328 is opening in my System running Windows 10 Home Edition 10.0.19045 and working fine…

Then I suggest try to launch server edition on your computer. Let’s see if you get any error. Without error it’s impossible to debug.