Can't open Manager

Hello all.
Few days back, something wrong happened to my PC and after that i can’t open Manager. Every time I try to open, the sand clock keeps working for approximately 30 seconds and then there’s nothing. I re-installed and tried, but still nothing is happening. I have saved all data of my business for last 5-6 months, and now this disaster happened.

Any one knows any solution, please share .

I can only assume there is something wrong with your computer. Have you tried downloading the program on another computer?

What OS? Windows? Version?
When you say something went wrong with your PC, what went wrong? Was this after a recent Windows update?
What version of do you have? Have you tried downloading the latest version of
Did you try Uninstalling prior to re-installing it?

Hello all. Thanks for your reply. I have uninstalled and reinstalled Manager in my Laptop. I also tried it in my friends laptop. But nothing is happening. My current Windows version is Windows 10 Version 1607 for x64-based Systems

Did you try a new download of
Did it stop working after a windows update?
Can you check your anti-virus/malware software to see if it has flagged Manager as malware.

Why don’t you do a system restore for a date prior to the problem - say Oct 15 or earlier.
It seems strange that you have tried it on a friend’s laptop and still nothing is happening.
Make sure you download by clicking the edition at the top of this forum page and not a third party website.
Are all other programs functioning ok.