DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Manager doesn't seem to be retaining data


#1

After entering 14 months of data without a problem, and very happy with how Manager works, I can’t get it to save the 15th month. I’ve now spent many hours twice entering this data and when I reopen it, it only shows to the end of the 14th month. I don’t know where the other data has gone. I had backed up the data but when I try to open the back-up I get this message: ‘The document “Rockhouse Mob.manager” could not be opened. Manager cannot open files of this type.’

I’m running Manager 15.0.12 on an iMac with 8Gb of RAM and OSX Yosemite 10.10.2 (14C109)

Any clues?


#2

I hope your fix is simple, @greg_balding. On the Summary tab, click on the Customize button. Make sure you have the date range correct. You can set both beginning and end dates, and Manager will ignore transactions outside the range.

Normally, most people would set the “From” date as the beginning of the accounting period (typically the start of your financial year, but it could be a quarter or a month). The “Until” date is usually “Today.” That way, your Financial picture is always current.

This will not govern date ranges for Reports. Those can be defined as you wish, too. But you have the option of saving old reports (such as for prior financial years) along with the current one.

The backup file itself cannot be opened directly, at least not on a Mac. It can be used to restore data by following instructions in the Guides for importing data:

http://www.manager.io/guides/miscellaneous/backing-up-and-restoring-data/

Let us know if these suggestions worked.


#3

So if you enter invoice under Sales Invoices tab, you can see it there. When you restart your computer, it’s gone?


#4

Thanks so much, Tut. The second of your suggestions, importing the backup
according to the guide, opened another version with all the data. I deleted the one with the missing data and all is
good :slight_smile:

I have to say, I am astonished at how easy and neat your software is to
use, after having battled with several others, and perfect for my fairly
simple needs. Well done!


#5

Glad it worked, @greg_balding. I will bet @lubos still wants to figure out where things went wrong, though. Manager inherently doesn’t lose data.

Did you verify the date settings on the original file according to my first suggestion? And did the problem still persist?


#6

Yes the date range on Summary/Customize was right (beginning of accounting period > Today) but still the data were missing. I had saved PDFs of reports for the period but I was worried I’d lose more data if I kept re-entering it or continuing. I’m happy now but it is a bit weird.