Mac Application crash on Report Print > PDF > Save as PDF

Trying to save a General Ledger Transaction report to PDF but app crashes and dies every time I try Print > PDF > ‘Save to PDF’. No issues doing same with other reports I’ve tried. Report is 25 pages long.

Tried a few times and it worked eventually. Can’t see how I can attach crash reports but I have them if needed…

Use the Upload icon (bar with up arrow) which appears above the topic/reply text box

Doh! Could have sworn that the menu bar wasn’t there… It’s late here tho so maybe that’s it :slight_smile:

In any case I still couldn’t upload the files because they’re not in an allowed format. Tried changing the file extension but that didn’t work either.

Instead here are dropbox links to the files:

Hopefully they will shed some light on the issue!

Hi, yes i faced also several time the same issue on Purchase order and sales order. Suddenly then manager close, restart again then maybe it works or maybe restart again. (only have 1 or 2 pages)

There is no solution to this problem. This issue is happening outside of Manager.

I’m planning to solve it by making Manager to generate PDF files internally rather than relying on operating system. For the time being, you can generate PDF documents by emailing them yourself using Email button.

1 Like

but this problem never was before, just the last updates i faced this problem

Facing the same problem since a few months now.
Today I upgraded agina to a fresh version, coming form 16.x to 17.x (Mac).
Still pdf printingcauses manager to abort, too when mailing it to myself.
In 16.x I could work around it in the suggested way (mail to self), but now I can´t generate invoices anymore to forward them to to my customers, This UNLESS I use the default format rather than my own template with logo etc. HELP

@Maerel, when you say you are using a “template,” do you mean an old view template, or do you mean a custom theme? (Themes were introduced in November 2016.) If still using a template, replace it with a customer themes. See this release note:

[16.11.24] Added ability to create custom themes.

Dear Tut,

Thanks for quick response!

Rather than template, I meant themes indeed. Looking at the HTML and “ business logo” I remembered I switched over form laptop to iMac back in November. The problem then appears first. Replacing logo within the general settings solved it.
Sorry for bothering and thanks again, for providing the direction where to search!

Best regards,

Please keep personal and commercial information off the forum. I’ve removed your business card from your last post.

1 Like