Lost previous custom templates

Hi all,

I recently updated Manager (yes, I backed up first) and selected a few of the pre-built Invoice templates just to get familiar with the process. I am able to use Switch Template and toggle through them, but I no longer have the option of using the customized default template that I created. Interestingly, the original Invoice template is the default, but since View Templates is gone, I can no longer add that custom field I created for certain clients. Is there a way to get those previous customized templates back?

No. View templates were supported as a legacy feature through the previous major revision, when custom themes were added. Now, support for them has been dropped. View templates were written in HTML. Themes and templates are both in Liquid.

But your custom fields are still valid. If they have content, they appear in the default template below the totals. (Notes is just a built-in custom field, but is handled by the same code that presents other custom fields.) If a particular custom field is empty, it and its label will not be displayed. I am assuming, here, that your custom field is really a custom field defined under Settings, not just some additional HTML code you put into the old view template.

Thanks for the quick reply.

The Custom Fields do show up when I’m creating the Invoice, but when I “Update” to get to the print page, those populated fields don’t show up in the print ready Invoice. And I no longer have the option to select those alternate templates (i.e. “w/job # on top”, “w/job number below invoice #”, etc.).

I’d be willing to try to customize the default again, but I don’t see a way to do that.

Custom fields need to have the box checked to show on printed documents if you want them to appear. Otherwise they just for internal use. Do this under Settings by editing the custom field.

Templates are also under Settings. Copy the baseline code from the Templates page accessible from the top menu bar. Follow instructions in the release note about templates.

Yes, thanks. I just noticed that checkbox for the custom field and checked it. It is now showing up, although ideally I would like to be able to have it appear in a specific place near the top of the invoice rather than just at the bottom. I don’t see an obvious way to change that when looking at the code for the template. But that’s probably because I don’t know Liquid. :slight_smile:

1 Like

If you’re a coder, I think it is simple. If you’re not, it isn’t trivial. Any web developer should be able to help.