Invoices changed

Since I have upgraded to the new version I have lost my banking details which I had at the bottom left hand side can anyone help as to how to get it back.

That depends on how you had placed your information there and in what version you did it. Had you created a custom view template? Was the information in a custom field? Was it entered in the Business Identifier field under Settings => Business Details? What version are you running now? What edition are you using: desktop, server, or cloud?

Hi Tut
The version that I was running was 15.6.97 and it was in settings Sales invoice template that I used I now see that this is no in the new version that I have which is 16.11.87. What I need is to be able to put this information back on the invoices. By the way I am using desktop edition

That feature disappeared so long ago, I don’t recall it’s exact nature. If I remember correctly, though, you could enter information that would basically appear as a footer.

Things you want below the main invoice body must now go into the Notes field. You can set default text there:

The field accepts HTML code, so you have a great deal of flexibility in what you can do. You can also create additional custom fields.

Thanks for that also at the top of page in heading it is INVOICE can I change this to TAX INVOICE

If you use a built-in tax code for a country that requires invoices to be titled as Tax Invoice, it should happen automatically. Otherwise, you can do it with custom themes, but it would take a bit of programming.

Have tried that and unless I type it in every invoice it does not go into all invoices it would be easier to put the sales invoice template back

I don’t understand what you mean, @hammers. Unless you type what into every invoice? And where? There is no place to type in a different title except on sales quotes.

The sales invoice template Settings category is not coming back, because it would conflict with several previous improvements to the program and is totally incompatible with themes.

Have now got the bank details back at the bottom left in the notes,
but I need the invoice to have a heading of Tax Invoice other wise some of my costumers will not pay

You did not answer my question.

In answer to your question it was my bank details

See [16.11.1] Added new themes for invoices, quotes, orders, receipts etc (about half way through)

@lohjonming had the same requirement and Lubos was kind enough to let us know code needed for custom theme.

(A basic knowledge is needed to adjust your theme to get Tax Invoice)

Have you set up a built-in country tax code under Settings - Tax Codes.
If yes, then the Tax Invoice heading should appear on the invoices - if not, which country

I thought your comment about “type it into every invoice” applied to the Tax Invoice heading. Since you were referring to your bank information, you have to set that as default text. I showed you where with the screen shot I posted earlier. Note that default text only applies to future forms, not past ones.

As for your Tax Invoice heading, two moderators have already told you that built-in tax codes for countries requiring this automatically substitute it. Otherwise, you have been referred to other topics where code substitutions are provided.

As others have said, setting your tax codes correctly will automatically make your Invoice a Tax Invoice.

These are found in Settings > Tax Codes:

Ensure you have a valid tax code selected, for me it’s Aussie 10% GST (GST Free will only generate an Invoice, not a Tax Invoice)

In the absence of that, create a custom theme from anywhere you can see the invoice, and find where title appears between curly braces:

and replace that with:

{{ title | replace: "Invoice", "Tax Invoice" }}
1 Like

Hi All
Thanks for your input and help with my problem have now got all working well.

I need to change the heading on my invoice from INVOICE to TAX INVOICE, When i replace {{ title}} with the words TAX INVOICE, it changes the headings of all my documents of the even sales quotes are called TAX INVOICE. Even if i create a new theme all documents will adopt the title of the theme that i change so. So if i have opened PURCHASE INVOICE and change the theme to the newly created theme template, when i open an invoice it will be called the title of the theme i selected in purchase invoice.

How do i assign a theme template i have created to one document type and not apply to all?

@Thapelo_Nteta Try this:

Thanks for the reply, that solved one problem and created another, but i can live with the other problem of the Purchase Invoice now being called a Purchase Tax Invoice. However, there were two solutions posted and after i read the first option i can’t seem to find the replies that were posted.

Try my previous post. :point_up_2: Wont be able to copy and paste i’m afraid, not sure how to upload code?