Likely bug in Mac Desktop version

When using the “print” function from a selected report (in my case P&L), Manger hangs if you try to “Scale” the report (e.g. in order to fit on 1 page). The same hang also happens if you select a different “paper size” in the print menu.

I also tried to save to “pdf” (from the Print menu) and the same hang happens when scaling (so it is not associated to a specific printer).

I’m using;
OSX: 10.11.4
Manager: 16.3.18

These are known problems. See, for example, Email PDF files are all in A4 format. Eventually, they will be fixed. Your workaround for now is to print as a PDF, then work with the PDF itself. Not a complete solution, obviously.

@Tut, ability to email PDF files in US Letter format has been already added. And this issue seems unrelated to what you’ve posted.

If nobody is able to reproduce this issue on OSX, then it’s probably something outside of Manager.

What about other programs @AnBe? Can you print from them without any issues?

I was already aware of the paper size selection–A4 vs. U.S. Letter. I never regarded that as a bug, just a design characteristic.

I assumed what @AnBe was talking about was trying to scale the document, regardless of paper size. That is still an issue. That is, if you type a scale factor into the print dialog box, the program hangs. The only way out is to Force Quit. I have just confirmed this with latest version.

Yes, I’m sorry if the “paper size” selection cause a misunderstanding. This has nothing to do with A4 vs Us letter size.

The main issue is when using the % Scale for printing. Regardless if “saving to pdf” or printing to any printer this causes Manger to freeze. There is no problem doing the same from any other application.

The reason why I wanted to use this function was to allow one report to fit on 1 page.

I added the “paper selection” information as help for troubleshooting only. What I tried was to select “A3” (as I then thought I could “fool” manager to allow everything on one page) but Manager still freeze. (I assume this selection triggers a background scaling or something similar…)


I tested this on my Mac and I can scale the print size all day long without it freezing.
I then tried on a second Mac and that one freezes when attempting any scaling.

On the Mac that froze I tried resetting the printing system, to no effect, and trying under a new user with a fresh Manager data file, also to no effect.
I’ll have to see if I can break my other Mac. :smiley:

On a semi-related note, if you have to force quit Manager it does not quit completely. There is a second process still stuck churning up CPU cycles. The more you force quit the more rogue Managers you have running.
Either quit them individually from Activity Monitor, or open Terminal and run “killall Manager” (without quotes). A restart would also clear them out.

How very interesting it was to learn this. Who knew? (Well, obviously, you did, @smi89.) Thanks for the tip.

What distinguishes your two Macs that one would show the scaling freeze and the other would not? That difference may well be the key to fixing the problem.

1 Like

I only checked because the fans were ramping up and the computer was getting sluggish.

What distinguishes your two Macs that one would show the scaling freeze and the other would not? That difference may well be the key to fixing the problem.

Like I say, I’ll have to have a good look, but nothing stands out immediately. They’re both Core2 Duos on latest El Capitan with NVidia graphics, both set up for the same printer.
Oh, the intrigue…

Sometime this month, Manager on OS X will migrate to the latest version of Mono. It could solve these issues.

I downloaded latest MAC version today, 16.4.53, and this problem is still there. Has the latest Mono version been deployed …? If so, the scaling problem was not resolved by this migration…

New Mono framework has been implemented. When I tried scaling in the print dialog box, I no longer get the endless twirling beach ball like I used to. Instead, I get this:

Interestingly, if all I do is add to the default 100% in the dialog box, such as adding a 1 to make the scale 1001%, it works fine. The problems arise when deleting or replacing characters in the scale box.

Yes… I have the same problem…

I’m not planning to look into this further.

The plan is to add into Manager ability so it can produce PDF documents internally without relying on Mac OS. Once that is done, this issue will go away as Print button will work a bit differently.