Email PDF files are all in A4 format

All PDF files generated internally using the Email function (e.g. Sales Invoices) are configured for A4 paper, regardless of the system setting and even if the system’s PDF printer driver is set to another size (like US Letter). Please allow the internal PDF driver’s paper size to be configured by the user (or at least follow the default regional setting), so that invoices emailed directly from Manager are produced in the expected paper size.

Problems with PDF generation have been extensively reported and acknowledged. Fixes have been promised. Until that happens, the best approach seems to be to “print” or save locally as a PDF (exact procedure depending on your operating system) and attach to a regular email.

Thanks. I didn’t find this specific issue posted on the Forum yet.

This is probably just a setting for Manager’s internal PDF driver. It would think it might be reasonably straightforward to make that setting available to the end-user. Perhaps this could be added to the wishlist. (The A4 page size that Manager generates wind up getting cut off at the top and bottom when printed on US Letter paper without scaling. It’s confusing to customers. The alternative workflow suggested by @Tut certainly works, but the Email feature of Manager is extremely convenient, so it would be nice if this could be fixed.)

@lubos, is there any chance this would be an easy fix that you could fit into the short-term roadmap?

This is something I knew someone will eventually notice. I will do this within a few weeks.

Bumping this up in the hope that this fix is coming. Now that the Email function has been markedly improved with BCC, multiple recipients, and easily configurable display name, all it needs to be perfect is to use the regionally appropriate (or configurable) PDF paper size.

At a minimum, reports prepared by Manager’s internal PDF printer driver ought to be formatted so nothing but white space is cut off from the top or bottom if printed “as is” on US Letter paper, and so nothing but white space is cut off from the sides if printed “as is” on A4 paper (translation: slightly wider margins all around). Better yet would be a Business-level (or install-level) paper size setting for the internal PDF driver, or basing the paper size on the host system’s regional settings.

In the latest version (16.2.26), you can go to Email Settings and set your paper size format to Letter

1 Like

So nice! Thank you, @lubos!